summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraeme Lawes <graemelawes@gmail.com>2019-08-18 16:02:11 -0400
committerJoonas Niilola <juippis@gentoo.org>2019-10-11 16:48:02 +0300
commit4f27fffbe0b6b4bd831e7aa2e57936bae277fcc5 (patch)
tree59ef268402ecf2829a37d952a58a57d395e7c7d6 /sys-cluster/teleport
parentnet-proxy/3proxy: bump to 0.8.13 (diff)
downloadgentoo-4f27fffbe0b6b4bd831e7aa2e57936bae277fcc5.tar.gz
gentoo-4f27fffbe0b6b4bd831e7aa2e57936bae277fcc5.tar.bz2
gentoo-4f27fffbe0b6b4bd831e7aa2e57936bae277fcc5.zip
sys-cluster/teleport: add v4.0.9
Signed-off-by: Graeme Lawes <graemelawes@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster/teleport')
-rw-r--r--sys-cluster/teleport/Manifest1
-rw-r--r--sys-cluster/teleport/teleport-4.0.9.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-cluster/teleport/Manifest b/sys-cluster/teleport/Manifest
index a559443c10b8..a2440933ea54 100644
--- a/sys-cluster/teleport/Manifest
+++ b/sys-cluster/teleport/Manifest
@@ -1,2 +1,3 @@
DIST teleport-3.2.6.tar.gz 22620079 BLAKE2B 07b4bcb5b53a511c25f0556fad33b461307b524554e993097f634b1751d7fd3c664de0478427efa18dc20e597fb73f3c5bd09ba961754456245e1306372ed0ee SHA512 20be34820f9b9f29c492f8dabe8914012b66ebfb9db51f3dff0e19b8a1f7b85b948cc1036861d03ca6de9e6f30ba0b43caf4760bc95c74e45a38f0cad080820c
DIST teleport-4.0.1.tar.gz 34914632 BLAKE2B 88861a36b4cea94d24ccbb03294202a88845f444df31642b2878d8e3c9c0f46f4ed70b4f713e32889895e59be3629c1e861446c051ea5a74aaa4b7b044f17f6b SHA512 db5d477e430fc7d439e352a2e6605f6662a206b0395268f19d52422994344e1b26bb89f4eae0dd0a453cc0e3d19549bd03959e37e29dccf2b8504994922eb946
+DIST teleport-4.0.9.tar.gz 34927445 BLAKE2B 267ef0ab269efc405f0522a6442d9b626dea62c800717cf01a9f0bdf40a34015b218c58cbd0e5ccbdd17634e91516ece35f6bbfb17864411ef02ae60cf3391eb SHA512 6a9fb59780d4da7f62a2f204f7f2e4321a7b73d9fd60e2de7d7ac1cdcf05e24895115e754aacdbdb75f4c21d40f1e42808e7f4e6bbb54df461167b45ebb7de24
diff --git a/sys-cluster/teleport/teleport-4.0.9.ebuild b/sys-cluster/teleport/teleport-4.0.9.ebuild
new file mode 100644
index 000000000000..5421480e2d1b
--- /dev/null
+++ b/sys-cluster/teleport/teleport-4.0.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-build systemd
+
+DESCRIPTION="Modern SSH server for teams managing distributed infrastructure"
+HOMEPAGE="https://gravitational.com/teleport"
+
+EGO_PN="github.com/gravitational/${PN}/..."
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 golang-vcs
+ EGIT_REPO_URI="https://github.com/gravitational/${PN}.git"
+else
+ inherit golang-vcs-snapshot
+ SRC_URI="https://github.com/gravitational/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+IUSE="pam"
+LICENSE="Apache-2.0 MIT BSD ISC"
+RESTRICT="test strip"
+SLOT="0"
+
+BDEPEND="app-arch/zip"
+RDEPEND="pam? ( sys-libs/pam )"
+
+src_compile() {
+ BUILDFLAGS="" GOPATH="${S}" emake -j1 -C src/${EGO_PN%/*} full
+}
+
+src_install() {
+ keepdir /var/lib/${PN} /etc/${PN}
+ dobin src/${EGO_PN%/*}/build/{tsh,tctl,teleport}
+
+ insinto /etc/${PN}
+ newins "${FILESDIR}"/${PN}.yaml ${PN}.yaml
+
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+
+ systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
+ systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
+}
+
+src_test() {
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*} test
+}