summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-11-27 20:16:21 +0100
committerMarek Szuba <marecki@gentoo.org>2020-11-27 20:17:32 +0100
commit042c5518208622a434f1574067e1249b856c5a8f (patch)
tree2c818ed7d1ac2e28c95bd6bc2a748f0d78166676 /sys-cluster
parentmedia-gfx/gmic: bump to 2.9.4 (diff)
downloadgentoo-042c5518208622a434f1574067e1249b856c5a8f.tar.gz
gentoo-042c5518208622a434f1574067e1249b856c5a8f.tar.bz2
gentoo-042c5518208622a434f1574067e1249b856c5a8f.zip
sys-cluster/singularity: bump to 3.7.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/singularity/Manifest1
-rw-r--r--sys-cluster/singularity/singularity-3.7.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index 11c8215ef1ec..11ad8bcaf3ee 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1 +1,2 @@
DIST singularity-3.6.4.tar.gz 6183277 BLAKE2B 9fe9b28828149268506e4db895767528a9397c347905c170e96d8e0d7b9d715e4c5f212bf04a2418689f448e8045e52a16c8cc4e93a8066d4d651f1eeb918e92 SHA512 c12cdc6baba6089576396c4391367451a264d6bfe7dd9a4b582d21ee5bd49aeea79372f3d008a4f2f535af307e0890a8d1a72773bb2c0898872eed8c82e48991
+DIST singularity-3.7.0.tar.gz 6097313 BLAKE2B 2fa8472bea80fec2613d1598d89354c3655eadee2292f0a4921d680300bc5793c5721f9640aeb398eba6cc91540f132b9d9b2afa175e74ac9f53c8847ff21e13 SHA512 25faadd9b1ec4b9751534cf1176f294696c9afde50adbc42f67d86584a5122fc78500e4ac6c502e5d90a66a9b44b9097a4d0231afcc2615b25d95feab8a3c967
diff --git a/sys-cluster/singularity/singularity-3.7.0.ebuild b/sys-cluster/singularity/singularity-3.7.0.ebuild
new file mode 100644
index 000000000000..23232305c173
--- /dev/null
+++ b/sys-cluster/singularity/singularity-3.7.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="Application containers for Linux"
+HOMEPAGE="https://sylabs.io"
+SRC_URI="https://github.com/hpcng/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network +suid"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+COMMON="sys-libs/libseccomp"
+BDEPEND="virtual/pkgconfig"
+DEPEND="${COMMON}
+ >=dev-lang/go-1.13.0
+ app-crypt/gpgme
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup"
+RDEPEND="${COMMON}
+ sys-fs/squashfs-tools"
+
+CONFIG_CHECK="~SQUASHFS"
+
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ local myconfargs=(
+ -c "$(tc-getBUILD_CC)" \
+ -x "$(tc-getBUILD_CXX)" \
+ -C "$(tc-getCC)" \
+ -X "$(tc-getCXX)" \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --runstatedir=/run \
+ --localstatedir=/var \
+ $(usex network "" "--without-network") \
+ $(usex suid "" "--without-suid")
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${ED}" -C builddir install
+ keepdir /var/singularity/mnt/session
+
+ # As of version 3.5.3 this seems to be very much broken, affecting
+ # commands which have got nothing to do with singularity (example:
+ # completion on 'udisks mount -b /dev/' rejects all files from that
+ # directory other than 'autofs'). Moreover, this should go into
+ # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
+ # Hopefully temporary, which is why we delete this at install time
+ # instead of patching build scripts not to generate bash-completion
+ # data in the first place.
+ rm -rf "${ED}"/etc/bash_completion.d || die
+
+ dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
+ if use examples; then
+ dodoc -r examples
+ fi
+}