summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2020-08-21 19:57:36 +0200
committerMarc Schiffbauer <mschiff@gentoo.org>2020-08-21 20:05:51 +0200
commit05b4374649b60e5aed18180481f35c7b2095aeca (patch)
tree65af1910e1d23d3ae758a85ad846ce6607646897 /sys-cluster
parentacct-user/sanlock: added (diff)
downloadgentoo-05b4374649b60e5aed18180481f35c7b2095aeca.tar.gz
gentoo-05b4374649b60e5aed18180481f35c7b2095aeca.tar.bz2
gentoo-05b4374649b60e5aed18180481f35c7b2095aeca.zip
sys-cluster/sanlock: add new version
Bug: https://bugs.gentoo.org/718532 Closes: https://bugs.gentoo.org/721594 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/sanlock/Manifest1
-rw-r--r--sys-cluster/sanlock/files/sanlock-fence_sanlock-LDFLAGS.patch12
-rw-r--r--sys-cluster/sanlock/sanlock-3.8.2.ebuild85
3 files changed, 98 insertions, 0 deletions
diff --git a/sys-cluster/sanlock/Manifest b/sys-cluster/sanlock/Manifest
index d3a63ecac010..517da432a437 100644
--- a/sys-cluster/sanlock/Manifest
+++ b/sys-cluster/sanlock/Manifest
@@ -1,2 +1,3 @@
DIST sanlock-3.6.0.tar.gz 221666 BLAKE2B 7fe95bd6813c13b76993b343a5ad605c7ba642583987ffa5fef583f34c053ee62b0f9e5979f5b5cb9e4fcde53268ae3debc5ec36b04f6651cc4cb902dff52df9 SHA512 59eb2a6f12e95d54886fdf6d56fd9a6814dd20fe11f39664f2bb82a56326fee48c9465ae30e6d04f970c8f1b0d9c2e22b90d21ab1f657c6d6b61ff9f02332443
DIST sanlock-3.8.0.tar.gz 262077 BLAKE2B c5638dc405cb22098f551d2c267fb13ef8b59422d5d5fb64ade5273d27d6ef772178c1283860a180d3da053da46387e3687c69369c5447d90d7b04a61da80b92 SHA512 ec4e40066c8f5f25287265247509bcb9d8ae24e5bafdd563cb090e94df3fa65881c4814edeb81c50188e71990774d29e330b1dda864c22052fc936a9e2a0892a
+DIST sanlock-3.8.2.tar.gz 266780 BLAKE2B 5248d08225bcc2a19594a3dcd3872c8c69ca8b217d31f6263f2717e4594180d4ba4685c9679ce2f31b6a2dcb4fe9f3e6a5dd5ac3ed073aea02599e7bbc04390c SHA512 2fa92e16eee4d2f3dac452400522f7e90b93b71349d322564d5957e2d87fb4bd69f0b5617b05f4b296c272d6da9a404fccadbbfff106354a0e302c436593eaac
diff --git a/sys-cluster/sanlock/files/sanlock-fence_sanlock-LDFLAGS.patch b/sys-cluster/sanlock/files/sanlock-fence_sanlock-LDFLAGS.patch
new file mode 100644
index 000000000000..0fb00b364bad
--- /dev/null
+++ b/sys-cluster/sanlock/files/sanlock-fence_sanlock-LDFLAGS.patch
@@ -0,0 +1,12 @@
+diff -ur sanlock-3.8.2.orig/fence_sanlock/Makefile sanlock-3.8.2/fence_sanlock/Makefile
+--- sanlock-3.8.2.orig/fence_sanlock/Makefile 2020-08-21 19:48:12.695801870 +0200
++++ sanlock-3.8.2/fence_sanlock/Makefile 2020-08-21 19:47:50.477402437 +0200
+@@ -34,7 +34,7 @@
+ CFLAGS += -DVERSION=\"$(VER)\" -I../src -I../wdmd
+ CFLAGS += -fPIE -DPIE
+
+-LDFLAGS = -Wl,-z,now -Wl,-z,relro -pie
++LDFLAGS += -Wl,-z,now -Wl,-z,relro -pie
+ LDADD = -lrt -laio -lblkid -lsanlock -lwdmd
+
+ all: $(TARGET1) $(TARGET2)
diff --git a/sys-cluster/sanlock/sanlock-3.8.2.ebuild b/sys-cluster/sanlock/sanlock-3.8.2.ebuild
new file mode 100644
index 000000000000..449fd2f3274a
--- /dev/null
+++ b/sys-cluster/sanlock/sanlock-3.8.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit linux-info python-r1 systemd
+
+DESCRIPTION="shared storage lock manager"
+HOMEPAGE="https://pagure.io/sanlock"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+ GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ acct-user/${PN}
+ acct-group/${PN}
+ dev-libs/libaio
+ sys-apps/util-linux
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ ${FILESDIR}/sanlock-fence_sanlock-LDFLAGS.patch
+)
+
+pkg_setup() {
+ local warning="You need to have CONFIG_SOFT_WATCHDOG enabled in your kernel for wdmd"
+ if linux_config_exists; then
+ if ! linux_chkconfig_present SOFT_WATCHDOG; then
+ ewarn ""
+ ewarn "$warning"
+ ewarn ""
+ fi
+ else
+ ewarn ""
+ ewarn "Could not be checked automatically: $warning"
+ ewarn ""
+ fi
+}
+
+src_compile() {
+ for d in wdmd src fence_sanlock reset; do
+ cd $d; emake; cd ..
+ done
+ if use python; then
+ cd python; python_foreach_impl emake; cd ..
+ fi
+}
+
+src_install() {
+ for d in wdmd src fence_sanlock reset; do
+ cd $d; emake DESTDIR="${D}" LIBDIR="${EROOT}usr/$(get_libdir)" install; cd ..
+ done
+ if use python; then
+ cd python; python_foreach_impl emake DESTDIR="${D}" install; cd ..
+ fi
+
+ # config
+ dodir /etc/wdmd.d
+ dodir /etc/sanlock
+ insinto /etc/sanlock
+ doins src/sanlock.conf
+
+ # init
+ newconfd init.d/sanlock.sysconfig sanlock
+ newconfd init.d/wdmd.sysconfig wdmd
+ newinitd "${FILESDIR}"/sanlock.initd sanlock
+ newinitd "${FILESDIR}"/wdmd.initd wdmd
+ #doinitd ${FILESDIR}/sanlk-resetd.initd
+ #doinitd ${FILESDIR}/fence_sanlockd.initd
+
+ # systemd
+ systemd_newunit init.d/sanlock.service.native sanlock.service
+ sed -i 's,^ExecStartPre=,#ExecStartPre=,' init.d/wdmd.service.native
+ systemd_newunit init.d/wdmd.service.native wdmd.service
+ systemd_dounit init.d/sanlk-resetd.service
+ #systemd_dounit ${FILESDIR}/fence_sanlockd.service
+}