summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /sys-cluster
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/cinder/cinder-13.0.7.ebuild1
-rw-r--r--sys-cluster/cinder/cinder-14.0.1.ebuild1
-rw-r--r--sys-cluster/cinder/cinder-15.0.0.ebuild1
-rw-r--r--sys-cluster/cinder/cinder-2018.2.9999.ebuild1
-rw-r--r--sys-cluster/cinder/cinder-2019.1.9999.ebuild1
-rw-r--r--sys-cluster/cinder/cinder-2019.2.9999.ebuild1
-rw-r--r--sys-cluster/gasnet/gasnet-1.28.0.ebuild1
-rw-r--r--sys-cluster/gasnet/gasnet-1.28.2.ebuild1
-rw-r--r--sys-cluster/gasnet/gasnet-1.30.0.ebuild1
-rw-r--r--sys-cluster/hpx/hpx-0.9.99.ebuild3
-rw-r--r--sys-cluster/hpx/hpx-1.0.0.ebuild3
-rw-r--r--sys-cluster/hpx/hpx-1.1.0.ebuild3
-rw-r--r--sys-cluster/hpx/hpx-1.2.0.ebuild3
-rw-r--r--sys-cluster/hpx/hpx-1.2.1.ebuild1
-rw-r--r--sys-cluster/hpx/hpx-9999.ebuild1
-rw-r--r--sys-cluster/legion/legion-17.08.0.ebuild1
-rw-r--r--sys-cluster/legion/legion-17.10.0.ebuild1
-rw-r--r--sys-cluster/legion/legion-18.02.0.ebuild1
-rw-r--r--sys-cluster/legion/legion-18.05.0.ebuild1
-rw-r--r--sys-cluster/legion/legion-18.12.0.ebuild1
-rw-r--r--sys-cluster/legion/legion-19.06.0.ebuild1
-rw-r--r--sys-cluster/legion/legion-9999.ebuild1
-rw-r--r--sys-cluster/libcircle/libcircle-0.2.0_rc1.ebuild3
-rw-r--r--sys-cluster/libcircle/libcircle-0.2.1_rc1.ebuild3
-rw-r--r--sys-cluster/libqb/libqb-0.17.1.ebuild3
-rw-r--r--sys-cluster/libqb/libqb-0.17.2.ebuild3
-rw-r--r--sys-cluster/libqb/libqb-1.0.1.ebuild3
-rw-r--r--sys-cluster/libquo/libquo-1.2.9.ebuild3
-rw-r--r--sys-cluster/libquo/libquo-9999.ebuild3
29 files changed, 40 insertions, 11 deletions
diff --git a/sys-cluster/cinder/cinder-13.0.7.ebuild b/sys-cluster/cinder/cinder-13.0.7.ebuild
index b599d7a7b07b..4c8eb939d671 100644
--- a/sys-cluster/cinder/cinder-13.0.7.ebuild
+++ b/sys-cluster/cinder/cinder-13.0.7.ebuild
@@ -23,6 +23,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+api +scheduler +volume infiniband iscsi lvm mysql +memcached postgres rdma sqlite +tcp test +tgt"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( mysql postgres sqlite ) iscsi? ( tgt ) infiniband? ( rdma )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
diff --git a/sys-cluster/cinder/cinder-14.0.1.ebuild b/sys-cluster/cinder/cinder-14.0.1.ebuild
index 7b073f5c9a70..fda10c627766 100644
--- a/sys-cluster/cinder/cinder-14.0.1.ebuild
+++ b/sys-cluster/cinder/cinder-14.0.1.ebuild
@@ -23,6 +23,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+api +scheduler +volume infiniband iscsi lvm mysql +memcached postgres rdma sqlite +tcp test +tgt"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( mysql postgres sqlite ) iscsi? ( tgt ) infiniband? ( rdma )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
diff --git a/sys-cluster/cinder/cinder-15.0.0.ebuild b/sys-cluster/cinder/cinder-15.0.0.ebuild
index c688244a22a6..1debd3eab15e 100644
--- a/sys-cluster/cinder/cinder-15.0.0.ebuild
+++ b/sys-cluster/cinder/cinder-15.0.0.ebuild
@@ -23,6 +23,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+api +scheduler +volume infiniband iscsi lvm mysql +memcached postgres rdma sqlite +tcp test +tgt"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( mysql postgres sqlite ) iscsi? ( tgt ) infiniband? ( rdma )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
diff --git a/sys-cluster/cinder/cinder-2018.2.9999.ebuild b/sys-cluster/cinder/cinder-2018.2.9999.ebuild
index dedea484546e..23e3164d8658 100644
--- a/sys-cluster/cinder/cinder-2018.2.9999.ebuild
+++ b/sys-cluster/cinder/cinder-2018.2.9999.ebuild
@@ -23,6 +23,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+api +scheduler +volume infiniband iscsi lvm mysql +memcached postgres rdma sqlite +tcp test +tgt"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( mysql postgres sqlite ) iscsi? ( tgt ) infiniband? ( rdma )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
diff --git a/sys-cluster/cinder/cinder-2019.1.9999.ebuild b/sys-cluster/cinder/cinder-2019.1.9999.ebuild
index f5e2d68d7552..bf4f9da51b43 100644
--- a/sys-cluster/cinder/cinder-2019.1.9999.ebuild
+++ b/sys-cluster/cinder/cinder-2019.1.9999.ebuild
@@ -23,6 +23,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+api +scheduler +volume infiniband iscsi lvm mysql +memcached postgres rdma sqlite +tcp test +tgt"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( mysql postgres sqlite ) iscsi? ( tgt ) infiniband? ( rdma )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
diff --git a/sys-cluster/cinder/cinder-2019.2.9999.ebuild b/sys-cluster/cinder/cinder-2019.2.9999.ebuild
index 75715418265b..e9c432edc272 100644
--- a/sys-cluster/cinder/cinder-2019.2.9999.ebuild
+++ b/sys-cluster/cinder/cinder-2019.2.9999.ebuild
@@ -23,6 +23,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+api +scheduler +volume infiniband iscsi lvm mysql +memcached postgres rdma sqlite +tcp test +tgt"
+RESTRICT="!test? ( test )"
REQUIRED_USE="|| ( mysql postgres sqlite ) iscsi? ( tgt ) infiniband? ( rdma )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
diff --git a/sys-cluster/gasnet/gasnet-1.28.0.ebuild b/sys-cluster/gasnet/gasnet-1.28.0.ebuild
index ffe4c765a461..2bc9dbd32dcd 100644
--- a/sys-cluster/gasnet/gasnet-1.28.0.ebuild
+++ b/sys-cluster/gasnet/gasnet-1.28.0.ebuild
@@ -15,6 +15,7 @@ LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm"
IUSE="mpi test threads"
+RESTRICT="!test? ( test )"
DEPEND="mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
diff --git a/sys-cluster/gasnet/gasnet-1.28.2.ebuild b/sys-cluster/gasnet/gasnet-1.28.2.ebuild
index 4af06d5d78c8..f7b343704c77 100644
--- a/sys-cluster/gasnet/gasnet-1.28.2.ebuild
+++ b/sys-cluster/gasnet/gasnet-1.28.2.ebuild
@@ -15,6 +15,7 @@ LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm"
IUSE="mpi test threads"
+RESTRICT="!test? ( test )"
DEPEND="mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
diff --git a/sys-cluster/gasnet/gasnet-1.30.0.ebuild b/sys-cluster/gasnet/gasnet-1.30.0.ebuild
index 4af06d5d78c8..f7b343704c77 100644
--- a/sys-cluster/gasnet/gasnet-1.30.0.ebuild
+++ b/sys-cluster/gasnet/gasnet-1.30.0.ebuild
@@ -15,6 +15,7 @@ LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm"
IUSE="mpi test threads"
+RESTRICT="!test? ( test )"
DEPEND="mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
diff --git a/sys-cluster/hpx/hpx-0.9.99.ebuild b/sys-cluster/hpx/hpx-0.9.99.ebuild
index 871a7dee306b..742001e9ada5 100644
--- a/sys-cluster/hpx/hpx-0.9.99.ebuild
+++ b/sys-cluster/hpx/hpx-0.9.99.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,6 +23,7 @@ HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
SLOT="0"
LICENSE="Boost-1.0"
IUSE="doc examples jemalloc papi +perftools tbb test"
+RESTRICT="!test? ( test )"
RDEPEND="
tbb? ( dev-cpp/tbb )
diff --git a/sys-cluster/hpx/hpx-1.0.0.ebuild b/sys-cluster/hpx/hpx-1.0.0.ebuild
index 489183811659..0c4de411e176 100644
--- a/sys-cluster/hpx/hpx-1.0.0.ebuild
+++ b/sys-cluster/hpx/hpx-1.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,6 +23,7 @@ HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
SLOT="0"
LICENSE="Boost-1.0"
IUSE="doc examples jemalloc papi +perftools tbb test"
+RESTRICT="!test? ( test )"
RDEPEND="
tbb? ( dev-cpp/tbb )
diff --git a/sys-cluster/hpx/hpx-1.1.0.ebuild b/sys-cluster/hpx/hpx-1.1.0.ebuild
index 9f8589d79686..0c4de411e176 100644
--- a/sys-cluster/hpx/hpx-1.1.0.ebuild
+++ b/sys-cluster/hpx/hpx-1.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,6 +23,7 @@ HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
SLOT="0"
LICENSE="Boost-1.0"
IUSE="doc examples jemalloc papi +perftools tbb test"
+RESTRICT="!test? ( test )"
RDEPEND="
tbb? ( dev-cpp/tbb )
diff --git a/sys-cluster/hpx/hpx-1.2.0.ebuild b/sys-cluster/hpx/hpx-1.2.0.ebuild
index 9f8589d79686..0c4de411e176 100644
--- a/sys-cluster/hpx/hpx-1.2.0.ebuild
+++ b/sys-cluster/hpx/hpx-1.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,6 +23,7 @@ HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
SLOT="0"
LICENSE="Boost-1.0"
IUSE="doc examples jemalloc papi +perftools tbb test"
+RESTRICT="!test? ( test )"
RDEPEND="
tbb? ( dev-cpp/tbb )
diff --git a/sys-cluster/hpx/hpx-1.2.1.ebuild b/sys-cluster/hpx/hpx-1.2.1.ebuild
index a57d12d298d1..64c2d82ce771 100644
--- a/sys-cluster/hpx/hpx-1.2.1.ebuild
+++ b/sys-cluster/hpx/hpx-1.2.1.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
SLOT="0"
LICENSE="Boost-1.0"
IUSE="doc examples jemalloc papi +perftools tbb test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="?? ( jemalloc perftools tbb )"
diff --git a/sys-cluster/hpx/hpx-9999.ebuild b/sys-cluster/hpx/hpx-9999.ebuild
index a57d12d298d1..64c2d82ce771 100644
--- a/sys-cluster/hpx/hpx-9999.ebuild
+++ b/sys-cluster/hpx/hpx-9999.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
SLOT="0"
LICENSE="Boost-1.0"
IUSE="doc examples jemalloc papi +perftools tbb test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="?? ( jemalloc perftools tbb )"
diff --git a/sys-cluster/legion/legion-17.08.0.ebuild b/sys-cluster/legion/legion-17.08.0.ebuild
index 91e84737ce24..ec4705d91905 100644
--- a/sys-cluster/legion/legion-17.08.0.ebuild
+++ b/sys-cluster/legion/legion-17.08.0.ebuild
@@ -20,6 +20,7 @@ fi
LICENSE="BSD"
SLOT="0"
IUSE="gasnet +hwloc test"
+RESTRICT="!test? ( test )"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
diff --git a/sys-cluster/legion/legion-17.10.0.ebuild b/sys-cluster/legion/legion-17.10.0.ebuild
index 91e84737ce24..ec4705d91905 100644
--- a/sys-cluster/legion/legion-17.10.0.ebuild
+++ b/sys-cluster/legion/legion-17.10.0.ebuild
@@ -20,6 +20,7 @@ fi
LICENSE="BSD"
SLOT="0"
IUSE="gasnet +hwloc test"
+RESTRICT="!test? ( test )"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
diff --git a/sys-cluster/legion/legion-18.02.0.ebuild b/sys-cluster/legion/legion-18.02.0.ebuild
index 91e84737ce24..ec4705d91905 100644
--- a/sys-cluster/legion/legion-18.02.0.ebuild
+++ b/sys-cluster/legion/legion-18.02.0.ebuild
@@ -20,6 +20,7 @@ fi
LICENSE="BSD"
SLOT="0"
IUSE="gasnet +hwloc test"
+RESTRICT="!test? ( test )"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
diff --git a/sys-cluster/legion/legion-18.05.0.ebuild b/sys-cluster/legion/legion-18.05.0.ebuild
index 400a9b1facff..645888853571 100644
--- a/sys-cluster/legion/legion-18.05.0.ebuild
+++ b/sys-cluster/legion/legion-18.05.0.ebuild
@@ -20,6 +20,7 @@ fi
LICENSE="BSD"
SLOT="0"
IUSE="gasnet +hwloc test"
+RESTRICT="!test? ( test )"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
diff --git a/sys-cluster/legion/legion-18.12.0.ebuild b/sys-cluster/legion/legion-18.12.0.ebuild
index 400a9b1facff..645888853571 100644
--- a/sys-cluster/legion/legion-18.12.0.ebuild
+++ b/sys-cluster/legion/legion-18.12.0.ebuild
@@ -20,6 +20,7 @@ fi
LICENSE="BSD"
SLOT="0"
IUSE="gasnet +hwloc test"
+RESTRICT="!test? ( test )"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
diff --git a/sys-cluster/legion/legion-19.06.0.ebuild b/sys-cluster/legion/legion-19.06.0.ebuild
index 400a9b1facff..645888853571 100644
--- a/sys-cluster/legion/legion-19.06.0.ebuild
+++ b/sys-cluster/legion/legion-19.06.0.ebuild
@@ -20,6 +20,7 @@ fi
LICENSE="BSD"
SLOT="0"
IUSE="gasnet +hwloc test"
+RESTRICT="!test? ( test )"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
diff --git a/sys-cluster/legion/legion-9999.ebuild b/sys-cluster/legion/legion-9999.ebuild
index 400a9b1facff..645888853571 100644
--- a/sys-cluster/legion/legion-9999.ebuild
+++ b/sys-cluster/legion/legion-9999.ebuild
@@ -20,6 +20,7 @@ fi
LICENSE="BSD"
SLOT="0"
IUSE="gasnet +hwloc test"
+RESTRICT="!test? ( test )"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
diff --git a/sys-cluster/libcircle/libcircle-0.2.0_rc1.ebuild b/sys-cluster/libcircle/libcircle-0.2.0_rc1.ebuild
index 22e4e95e8f17..209b8ae5fe1c 100644
--- a/sys-cluster/libcircle/libcircle-0.2.0_rc1.ebuild
+++ b/sys-cluster/libcircle/libcircle-0.2.0_rc1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,6 +20,7 @@ HOMEPAGE="https://github.com/hpc/libcircle"
SLOT="0"
LICENSE="BSD"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="virtual/mpi"
DEPEND="${RDEPEND}
diff --git a/sys-cluster/libcircle/libcircle-0.2.1_rc1.ebuild b/sys-cluster/libcircle/libcircle-0.2.1_rc1.ebuild
index 22e4e95e8f17..209b8ae5fe1c 100644
--- a/sys-cluster/libcircle/libcircle-0.2.1_rc1.ebuild
+++ b/sys-cluster/libcircle/libcircle-0.2.1_rc1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,6 +20,7 @@ HOMEPAGE="https://github.com/hpc/libcircle"
SLOT="0"
LICENSE="BSD"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="virtual/mpi"
DEPEND="${RDEPEND}
diff --git a/sys-cluster/libqb/libqb-0.17.1.ebuild b/sys-cluster/libqb/libqb-0.17.1.ebuild
index b79bf5d082a9..95e2a5c5a792 100644
--- a/sys-cluster/libqb/libqb-0.17.1.ebuild
+++ b/sys-cluster/libqb/libqb-0.17.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,6 +15,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 hppa x86"
IUSE="debug doc examples static-libs test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-libs/glib:2"
DEPEND="${RDEPEND}
diff --git a/sys-cluster/libqb/libqb-0.17.2.ebuild b/sys-cluster/libqb/libqb-0.17.2.ebuild
index 8b80054d7eab..ca2a5f874d4f 100644
--- a/sys-cluster/libqb/libqb-0.17.2.ebuild
+++ b/sys-cluster/libqb/libqb-0.17.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,6 +15,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 hppa ppc ppc64 x86"
IUSE="debug doc examples static-libs test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-libs/glib:2"
DEPEND="${RDEPEND}
diff --git a/sys-cluster/libqb/libqb-1.0.1.ebuild b/sys-cluster/libqb/libqb-1.0.1.ebuild
index 748d05368bf3..55a12354c876 100644
--- a/sys-cluster/libqb/libqb-1.0.1.ebuild
+++ b/sys-cluster/libqb/libqb-1.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,6 +15,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="debug doc examples static-libs test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-libs/glib:2"
DEPEND="${RDEPEND}
diff --git a/sys-cluster/libquo/libquo-1.2.9.ebuild b/sys-cluster/libquo/libquo-1.2.9.ebuild
index 0b005031c633..dbc29394d12b 100644
--- a/sys-cluster/libquo/libquo-1.2.9.ebuild
+++ b/sys-cluster/libquo/libquo-1.2.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,6 +24,7 @@ HOMEPAGE="https://lanl.github.io/libquo/"
LICENSE="BSD"
SLOT="0"
IUSE="fortran static-libs test"
+RESTRICT="!test? ( test )"
DEPEND="
virtual/mpi[fortran?]
diff --git a/sys-cluster/libquo/libquo-9999.ebuild b/sys-cluster/libquo/libquo-9999.ebuild
index 88c33d14f348..cc7b789aa1b7 100644
--- a/sys-cluster/libquo/libquo-9999.ebuild
+++ b/sys-cluster/libquo/libquo-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,6 +23,7 @@ HOMEPAGE="https://lanl.github.io/libquo/"
LICENSE="BSD"
SLOT="0"
IUSE="fortran static-libs test"
+RESTRICT="!test? ( test )"
DEPEND="
virtual/mpi[fortran?]