summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-08-07 14:34:41 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-08-07 14:35:07 -0500
commit1973994f8ee782f1aaff6b62f99a9fd034f32924 (patch)
tree3316e5db30c5ffec575c9c214c795ea7d9947eb5 /sys-cluster
parentsys-cluster/nomad: 1.0.9 bump (diff)
downloadgentoo-1973994f8ee782f1aaff6b62f99a9fd034f32924.tar.gz
gentoo-1973994f8ee782f1aaff6b62f99a9fd034f32924.tar.bz2
gentoo-1973994f8ee782f1aaff6b62f99a9fd034f32924.zip
sys-cluster/nomad: remove vulnerable version
Bug: https://bugs.gentoo.org/797664 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/nomad/Manifest1
-rw-r--r--sys-cluster/nomad/nomad-1.0.4.ebuild45
2 files changed, 0 insertions, 46 deletions
diff --git a/sys-cluster/nomad/Manifest b/sys-cluster/nomad/Manifest
index c04d6e8247f7..babde4a95dd3 100644
--- a/sys-cluster/nomad/Manifest
+++ b/sys-cluster/nomad/Manifest
@@ -1,2 +1 @@
-DIST nomad-1.0.4.tar.gz 39538107 BLAKE2B ff72d527e23ce01a6ef0201e3606f4f66933f3c205123a32f503947710de3221476ce738b92becb147a8570c65bb5f4707fad480889197f605840197cfa13155 SHA512 935c8a6924434548f65b162c15f9ca14383546a1e0cea0694312f323d776d92863357f82c7ab53408e76c5c966986c0a511eda8a35043cf21c1020634c6e2ae4
DIST nomad-1.0.9.tar.gz 40563203 BLAKE2B 5db3bce093ae873907572e5f67640fac162e4c4ffe436f2acd3ac9fe8da509f451ff73c948dcd49d10eb101afdfe5285b2906986983b938034c64aab8d0cab4d SHA512 66a00f15a16b57e8a3f97c43301bd9aaab76e185b56fe45193eb0e7c25e83fbcf1a7072f2d5fe4c533a00e63c71f3ec941a05cf6aa50f5051b8f3b5588b50463
diff --git a/sys-cluster/nomad/nomad-1.0.4.ebuild b/sys-cluster/nomad/nomad-1.0.4.ebuild
deleted file mode 100644
index dc33a1137979..000000000000
--- a/sys-cluster/nomad/nomad-1.0.4.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit go-module systemd
-GIT_COMMIT=149b150fb2d87766b8462346d68b72831f622047
-
-DESCRIPTION="A simple and flexible workload orchestrator"
-HOMEPAGE="https://nomadproject.io"
-SRC_URI="https://github.com/hashicorp/nomad/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="nvidia"
-
-RESTRICT+=" test"
-
-src_compile() {
- local go_ldflags go_tags
- go_ldflags="-X github.com/hashicorp/nomad/version.GitCommit=${GIT_COMMIT}"
- go_tags="codegen_generated $(usex nvidia '' 'nonvidia')"
- CGO_ENABLED=1 \
- go build \
- -ldflags "${go_ldflags}" \
- -mod=vendor \
- -tags "${go_tags}" \
- -trimpath \
- -o bin/${PN} || die "compile failed"
-}
-
-src_install() {
- dobin bin/${PN}
- systemd_dounit dist/systemd/nomad.service
- insinto /etc/nomad.d
- newins dist/client.hcl client.hcl.example
- newins dist/server.hcl server.hcl.example
- einstalldocs
- dodoc CHANGELOG.md
- keepdir /var/lib/nomad /var/log/nomad
- newconfd "${FILESDIR}/nomad.confd" nomad
- newinitd "${FILESDIR}/nomad.initd" nomad
- insinto /etc/logrotate.d
- newins "${FILESDIR}/nomad.logrotated" nomad
-}