summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-09-01 11:37:48 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-09-01 11:38:23 +0300
commit3b5309c83440c7ab666cc8a1c128a49762b50f9d (patch)
tree4132bd057f12dd3a0e07555741435c917c06e1f2 /sys-cluster
parentnet-nds/shelldap: update HOMEPAGE, remove old (diff)
downloadgentoo-3b5309c83440c7ab666cc8a1c128a49762b50f9d.tar.gz
gentoo-3b5309c83440c7ab666cc8a1c128a49762b50f9d.tar.bz2
gentoo-3b5309c83440c7ab666cc8a1c128a49762b50f9d.zip
sys-cluster/rdma-core: Version bump (v31.0)
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/rdma-core/Manifest1
-rw-r--r--sys-cluster/rdma-core/rdma-core-31.0.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/sys-cluster/rdma-core/Manifest b/sys-cluster/rdma-core/Manifest
index 76aed9e56da9..4e8e3d9f1bba 100644
--- a/sys-cluster/rdma-core/Manifest
+++ b/sys-cluster/rdma-core/Manifest
@@ -1 +1,2 @@
DIST rdma-core-30.0.tar.gz 1485452 BLAKE2B 8774a41eaba486007a4b695fc5196935102c172607136ca37d03fa626c5bb0b75df7b9cc6a6126219111b4ba828984ffbb235e9afee1e941852650a2b2412dc7 SHA512 4a0ec689e27de71f33e21df9813f78bec81b99c941da234d8d4050a3e1a1b157488d7a4d58d7f62472f32061a36dadad43d986238dcbaf24a29dded3827ec374
+DIST rdma-core-31.0.tar.gz 1501133 BLAKE2B 5e67d68ab8eb4019ffb18e7d1995caa8e84a2136201c8649f64093a6c8b8c7b8255e997c12bfd38f33de5608e0fa58a35a1a45e144cf9a65bde671a9f087de1c SHA512 b453343d419ccdc7eb0ae7092dfc84cfcd39b0b64a3e4b3bae18b5078f8e9ce7b2c1c126c535372d4717bb5af3cf2ca26a70e271f00631c66077e619814865c0
diff --git a/sys-cluster/rdma-core/rdma-core-31.0.ebuild b/sys-cluster/rdma-core/rdma-core-31.0.ebuild
new file mode 100644
index 000000000000..794a91cb6c06
--- /dev/null
+++ b/sys-cluster/rdma-core/rdma-core-31.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake python-single-r1 udev systemd
+
+DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
+HOMEPAGE="https://github.com/linux-rdma/rdma-core"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/linux-rdma/rdma-core"
+else
+ SRC_URI="https://github.com/linux-rdma/rdma-core/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+LICENSE="|| ( GPL-2 ( CC0-1.0 MIT BSD BSD-with-attribution ) )"
+SLOT="0"
+IUSE="neigh python static-libs systemd valgrind"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="
+ virtual/libudev:=
+ neigh? ( dev-libs/libnl:3 )
+ systemd? ( sys-apps/systemd:= )
+ valgrind? ( dev-util/valgrind )
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${COMMON_DEPEND}
+ python? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
+
+RDEPEND="${COMMON_DEPEND}
+ !sys-fabric/infiniband-diags
+ !sys-fabric/libibverbs
+ !sys-fabric/librdmacm
+ !sys-fabric/libibumad
+ !sys-fabric/ibacm
+ !sys-fabric/libibmad
+ !sys-fabric/srptools
+ !sys-fabric/infinipath-psm
+ !sys-fabric/libcxgb3
+ !sys-fabric/libcxgb4
+ !sys-fabric/libmthca
+ !sys-fabric/libmlx4
+ !sys-fabric/libmlx5
+ !sys-fabric/libocrdma
+ !sys-fabric/libnes"
+
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/optional_pandoc.patch )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc
+ -DCMAKE_INSTALL_RUNDIR=/run
+ -DCMAKE_INSTALL_SHAREDSTATEDIR=/var/lib
+ -DCMAKE_INSTALL_UDEV_RULESDIR="$(get_udevdir)"/rules.d
+ -DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_pandoc=yes
+ $(ver_test -ge 25 && echo -DCMAKE_DISABLE_FIND_PACKAGE_rst2man=yes)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Systemd="$(usex systemd no yes)"
+ -DENABLE_VALGRIND="$(usex valgrind)"
+ -DENABLE_RESOLVE_NEIGH="$(usex neigh)"
+ -DENABLE_STATIC="$(usex static-libs)"
+ )
+
+ if use python; then
+ mycmakeargs+=( -DNO_PYVERBS=OFF )
+ else
+ mycmakeargs+=( -DNO_PYVERBS=ON )
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ udev_dorules "${D}"/etc/udev/rules.d/70-persistent-ipoib.rules
+ rm -r "${D}"/etc/{udev,init.d} || die
+
+ if use neigh; then
+ newinitd "${FILESDIR}"/ibacm.init ibacm
+ fi
+
+ newinitd "${FILESDIR}"/iwpmd.init iwpmd
+ newinitd "${FILESDIR}"/srpd.init srpd
+
+ use python && python_optimize
+}