summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-03-22 15:29:35 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-03-22 15:32:11 -0700
commit4b1f971d7c5d842d3422d2e167e9d8e272820af1 (patch)
treef97b3774371c2c84c9cc2d47525e079cb8a276e1 /sys-cluster
parentapp-backup/spideroak-bin: remove older versions (diff)
downloadgentoo-4b1f971d7c5d842d3422d2e167e9d8e272820af1.tar.gz
gentoo-4b1f971d7c5d842d3422d2e167e9d8e272820af1.tar.bz2
gentoo-4b1f971d7c5d842d3422d2e167e9d8e272820af1.zip
sys-cluster/ceph: revbump 14.2.0-r1 static crc32 fork (bug #681216)
Statically link internal crc32 fork to avoid collisions and runtime errors. Closes: https://bugs.gentoo.org/681216 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ceph-14.2.0-r2.ebuild (renamed from sys-cluster/ceph/ceph-14.2.0-r1.ebuild)4
-rw-r--r--sys-cluster/ceph/files/ceph-14.2.0-link-crc32-statically.patch11
2 files changed, 14 insertions, 1 deletions
diff --git a/sys-cluster/ceph/ceph-14.2.0-r1.ebuild b/sys-cluster/ceph/ceph-14.2.0-r2.ebuild
index 868ca8e9fd71..d318002040a0 100644
--- a/sys-cluster/ceph/ceph-14.2.0-r1.ebuild
+++ b/sys-cluster/ceph/ceph-14.2.0-r2.ebuild
@@ -38,6 +38,7 @@ COMMON_DEPEND="
app-arch/snappy:=[static-libs?]
app-arch/zstd:=[static-libs?]
app-misc/jq:=[static-libs?]
+ dev-libs/crc32c:=
dev-libs/crypto++:=[static-libs?]
dev-libs/leveldb:=[snappy,static-libs?,tcmalloc?]
dev-libs/libaio:=[static-libs?]
@@ -149,6 +150,7 @@ PATCHES=(
"${FILESDIR}/ceph-14.2.0-no-virtualenvs.patch"
"${FILESDIR}/ceph-13.2.2-dont-install-sysvinit-script.patch"
"${FILESDIR}/ceph-14.2.0-dpdk-cflags.patch"
+ "${FILESDIR}/ceph-14.2.0-link-crc32-statically.patch"
)
# dpdk and ninja don't get along
@@ -228,7 +230,7 @@ ceph_src_configure() {
-DWITH_TBB=no
-DSYSTEMD_UNITDIR=$(systemd_get_systemunitdir)
-DEPYTHON_VERSION="${EPYTHON#python}"
- -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${P}"
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PN}"
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
-Wno-dev
)
diff --git a/sys-cluster/ceph/files/ceph-14.2.0-link-crc32-statically.patch b/sys-cluster/ceph/files/ceph-14.2.0-link-crc32-statically.patch
new file mode 100644
index 000000000000..ec7a4fb079b3
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-14.2.0-link-crc32-statically.patch
@@ -0,0 +1,11 @@
+--- ceph-14.2.0.orig/src/common/CMakeLists.txt 2019-03-18 04:08:29.000000000 -0600
++++ ceph-14.2.0/src/common/CMakeLists.txt 2019-03-21 18:42:32.903182824 -0600
+@@ -165,7 +165,7 @@
+ crc32c_aarch64.c)
+ endif(HAVE_INTEL)
+
+-add_library(crc32 ${crc32_srcs})
++add_library(crc32 STATIC ${crc32_srcs})
+ if(HAVE_ARMV8_CRC)
+ set_target_properties(crc32 PROPERTIES
+ COMPILE_FLAGS "${CMAKE_C_FLAGS} ${ARMV8_CRC_COMPILE_FLAGS}")