summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-06 15:48:20 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-06 16:07:07 +0100
commit4de4adf0420fca4d70fba4a2d5d5b7f8e4974789 (patch)
treeec83fa6911345a7181b643fa794d7a781b405ff9 /sys-cluster
parentdev-python/nose: Include enhancement suggested by mgorny (diff)
downloadgentoo-4de4adf0420fca4d70fba4a2d5d5b7f8e4974789.tar.gz
gentoo-4de4adf0420fca4d70fba4a2d5d5b7f8e4974789.tar.bz2
gentoo-4de4adf0420fca4d70fba4a2d5d5b7f8e4974789.zip
sys-cluster/mpe2: Drop old
obsoletes: Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=450942 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=478562 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild144
-rw-r--r--sys-cluster/mpe2/mpe2-1.0.6_p1-r2.ebuild3
-rw-r--r--sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild142
3 files changed, 2 insertions, 287 deletions
diff --git a/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild b/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild
deleted file mode 100644
index 9ae1133b00c4..000000000000
--- a/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=2
-
-FORTRAN_NEEDED=fortran
-
-inherit eutils fortran-2 java-utils-2 toolchain-funcs
-
-MY_P=${P/_/}
-DESCRIPTION="MPI development tools"
-HOMEPAGE="http://www-unix.mcs.anl.gov/perfvis/download/index.htm"
-SRC_URI="ftp://ftp.mcs.anl.gov/pub/mpi/${PN%2}/${MY_P}.tar.gz"
-
-LICENSE="mpich2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="minimal fortran threads debug"
-
-COMMON_DEPEND="!minimal? ( x11-libs/libXtst
- x11-libs/libXi )
- || ( sys-cluster/openmpi[fortran?,threads?]
- sys-cluster/mpich2[fortran?,threads?] )"
-
-DEPEND="!minimal? ( >=virtual/jdk-1.4 )
- ${COMMON_DEPEND}"
-
-RDEPEND="
-!minimal? ( >=virtual/jre-1.4 )
- ${COMMON_DEPEND}"
-
-S="${WORKDIR}"/${MY_P}
-MPE_IMP=""
-
-# README:
-# This ebuild is created to handle building with both mpich2 and openmpi.
-# However, without empi (in the science overlay), and some further
-# conversion to use mpi.eclass, we can only handle one implementation
-# at a time. I still believe it's better to have the ebuild setup
-# correctly in preperation.
-
-pkg_setup() {
- fortran-2_pkg_setup
- local i
-
- if has_version sys-cluster/openmpi; then
- MPE_IMP=openmpi
- elif has_version sys-cluster/mpich2; then
- MPE_IMP=mpich2
- else
- die "Unknown MPI implementation"
- fi
-
- export JFLAGS="${JFLAGS} $(java-pkg_javac-args)"
-
- if [[ "${MPE_IMP}" == openmpi ]] && [ -z "${MPE2_FORCE_OPENMPI_TEST}" ]; then
- echo
- elog "Currently src_test fails on collchk with openmpi, hence"
- elog "testing is disabled by default. If you would like to"
- elog "force testing, please add MPE_FORCE_OPENMPI_TEST=1"
- elog "to your environment."
- echo
- fi
-
- einfo "Building with support for: sys-cluster/${MPE_IMP}"
-}
-
-src_prepare() {
- # Don't assume path contains ./
- sed -i 's,\($MPERUN\) $pgm,\1 ./$pgm,' sbin/mpetestexeclog.in
- epatch "${FILESDIR}"/slog2sdk-trace_rlog-makefile-fixes.patch
- epatch "${FILESDIR}"/slog2sdk-trace_sample-makefile-fixes.patch
-}
-
-src_configure() {
- local c="--with-mpicc=/usr/bin/mpicc"
-
- if use fortran; then
- c="${c} --with-mpif77=/usr/bin/mpif77"
- else
- c="${c} --disable-f77"
- fi
-
- if use minimal; then
- c="${c} --enable-slog2=no --disable-rlog --disable-sample"
- else
- c="${c} --with-java2=$(java-config --jdk-home) --enable-slog2=build"
- fi
-
- if [[ "${MPE_IMP}" == openmpi ]]; then
- c="${c} --disable-rlog --disable-sample"
- fi
-
- econf ${c} \
- --sysconfdir=/etc/${PN} \
- --datadir=/usr/share/${PN} \
- --with-htmldir=/usr/share/${PN} \
- --with-docdir=/usr/share/${PN} \
- --enable-collchk \
- --enable-wrappers \
- $(use_enable !minimal graphics) \
- $(use_enable threads threadlogging) \
- $(use_enable debug g)
-}
-
-src_test() {
- local rc
-
- cd "${S}"
- if [[ "${MPE_IMP}" == mpich2 ]]; then
- echo "MPD_SECRETWORD=junk" > "${T}"/mpd.conf
- chmod 600 "${T}"/mpd.conf
- export MPD_CONF_FILE="${T}/mpd.conf"
- "${ROOT}"usr/bin/mpd -d --pidfile="${T}"/mpd.pid
- elif [[ "${MPE_IMP}" == openmpi* ]] && [ -z "${MPE2_FORCE_OPENMPI_TEST}" ]; then
- elog
- elog "Skipping tests for openmpi"
- elog
- return 0
- fi
-
- # No parallel make:
- # http://trac.mcs.anl.gov/projects/mpich2/ticket/1095#comment:1
- emake -j1 \
- CC="${S}"/bin/mpecc \
- FC="${S}"/bin/mpefc \
- MPERUN="${ROOT}/usr/bin/mpiexec -n 4" \
- CLOG2TOSLOG2="${S}/src/slog2sdk/bin/clog2TOslog2" \
- check;
- rc=${?}
- if [[ "${MPE_IMP}" == mpich2 ]]; then
- "${ROOT}"usr/bin/mpdallexit || kill $(<"${T}"/mpd.pid)
- fi
-
- return ${rc}
-}
-
-src_install() {
- # No parallel make:
- # http://trac.mcs.anl.gov/projects/mpich2/ticket/1095#comment:1
- emake -j1 DESTDIR="${D}" install || die
- rm -f "${D}"/usr/sbin/mpeuninstall || die
-}
diff --git a/sys-cluster/mpe2/mpe2-1.0.6_p1-r2.ebuild b/sys-cluster/mpe2/mpe2-1.0.6_p1-r2.ebuild
index 32ee5fe29c31..a0043d8dec5d 100644
--- a/sys-cluster/mpe2/mpe2-1.0.6_p1-r2.ebuild
+++ b/sys-cluster/mpe2/mpe2-1.0.6_p1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -154,4 +154,5 @@ src_install() {
MAKEOPTS+=" -j1"
default
rm -f "${ED}"/usr/sbin/mpeuninstall || die
+ rm -f "${ED}"/usr/bin/*.in || die
}
diff --git a/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild b/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild
deleted file mode 100644
index 76d6bf0033c8..000000000000
--- a/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild
+++ /dev/null
@@ -1,142 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=2
-
-FORTRAN_NEEDED=fortran
-
-inherit eutils fortran-2 java-utils-2 toolchain-funcs
-
-MY_P=${P/_/}
-DESCRIPTION="MPI development tools"
-HOMEPAGE="http://www-unix.mcs.anl.gov/perfvis/download/index.htm"
-SRC_URI="ftp://ftp.mcs.anl.gov/pub/mpi/${PN%2}/${MY_P}.tar.gz"
-
-LICENSE="mpich2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="minimal fortran threads debug"
-
-COMMON_DEPEND="!minimal? ( x11-libs/libXtst
- x11-libs/libXi )
- || ( sys-cluster/openmpi[fortran?,threads?]
- sys-cluster/mpich2[fortran?,threads?] )"
-
-DEPEND="!minimal? ( >=virtual/jdk-1.4 )
- ${COMMON_DEPEND}"
-
-RDEPEND="
-!minimal? ( >=virtual/jre-1.4 )
- ${COMMON_DEPEND}"
-
-S="${WORKDIR}"/${MY_P}
-MPE_IMP=""
-
-# README:
-# This ebuild is created to handle building with both mpich2 and openmpi.
-# However, without empi (in the science overlay), and some further
-# conversion to use mpi.eclass, we can only handle one implementation
-# at a time. I still believe it's better to have the ebuild setup
-# correctly in preperation.
-
-pkg_setup() {
- fortran-2_pkg_setup
- local i
-
- if has_version sys-cluster/openmpi; then
- MPE_IMP=openmpi
- elif has_version sys-cluster/mpich2; then
- MPE_IMP=mpich2
- else
- die "Unknown MPI implementation"
- fi
-
- export JFLAGS="${JFLAGS} $(java-pkg_javac-args)"
-
- if [[ "${MPE_IMP}" == openmpi ]] && [ -z "${MPE2_FORCE_OPENMPI_TEST}" ]; then
- echo ""
- elog "Currently src_test fails on collchk with openmpi, hence"
- elog "testing is disabled by default. If you would like to"
- elog "force testing, please add MPE_FORCE_OPENMPI_TEST=1"
- elog "to your environment."
- echo ""
- fi
-
- einfo "Building with support for: sys-cluster/${MPE_IMP}"
-}
-
-src_prepare() {
- # Don't assume path contains ./
- sed -i 's,\($MPERUN\) $pgm,\1 ./$pgm,' sbin/mpetestexeclog.in
-}
-
-src_configure() {
- local c="--with-mpicc=/usr/bin/mpicc"
-
- if use fortran; then
- c="${c} --with-mpif77=/usr/bin/mpif77"
- else
- c="${c} --disable-f77"
- fi
-
- if use minimal; then
- c="${c} --enable-slog2=no --disable-rlog --disable-sample"
- else
- c="${c} --with-java2=$(java-config --jdk-home) --enable-slog2=build"
- fi
-
- if [[ "${MPE_IMP}" == openmpi ]]; then
- c="${c} --disable-rlog --disable-sample"
- fi
-
- econf ${c} \
- --sysconfdir=/etc/${PN} \
- --datadir=/usr/share/${PN} \
- --with-htmldir=/usr/share/${PN} \
- --with-docdir=/usr/share/${PN} \
- --enable-collchk \
- --enable-wrappers \
- $(use_enable !minimal graphics) \
- $(use_enable threads threadlogging) \
- $(use_enable debug g)
-}
-
-src_test() {
- local rc
-
- cd "${S}"
- if [[ "${MPE_IMP}" == mpich2 ]]; then
- echo "MPD_SECRETWORD=junk" > "${T}"/mpd.conf
- chmod 600 "${T}"/mpd.conf
- export MPD_CONF_FILE="${T}/mpd.conf"
- "${ROOT}"usr/bin/mpd -d --pidfile="${T}"/mpd.pid
- elif [[ "${MPE_IMP}" == openmpi* ]] && [ -z "${MPE2_FORCE_OPENMPI_TEST}" ]; then
- echo
- elog "Skipping tests for openmpi"
- echo
- return 0
- fi
-
- # No parallel make:
- # http://trac.mcs.anl.gov/projects/mpich2/ticket/1095#comment:1
- emake -j1 \
- CC="${S}"/bin/mpecc \
- FC="${S}"/bin/mpefc \
- MPERUN="${ROOT}/usr/bin/mpiexec -n 4" \
- CLOG2TOSLOG2="${S}/src/slog2sdk/bin/clog2TOslog2" \
- check;
- rc=${?}
- if [[ "${MPE_IMP}" == mpich2 ]]; then
- "${ROOT}"usr/bin/mpdallexit || kill $(<"${T}"/mpd.pid)
- fi
-
- return ${rc}
-}
-
-src_install() {
- # No parallel make:
- # http://trac.mcs.anl.gov/projects/mpich2/ticket/1095#comment:1
- emake -j1 DESTDIR="${D}" install || die
- rm -f "${D}"/usr/sbin/mpeuninstall || die
-}