summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2016-01-26 09:24:53 +0100
committerUltrabug <ultrabug@gentoo.org>2016-01-26 09:25:28 +0100
commit5164e4602e2256ae79ade43fb9023b2b4fdc5d19 (patch)
tree2370f772e814e6132d5d72751bc17f6a20e041ff /sys-cluster
parentdev-texlive/texlive-langeuropean: block tl-langlatin, bug #572918 (diff)
downloadgentoo-5164e4602e2256ae79ade43fb9023b2b4fdc5d19.tar.gz
gentoo-5164e4602e2256ae79ade43fb9023b2b4fdc5d19.tar.bz2
gentoo-5164e4602e2256ae79ade43fb9023b2b4fdc5d19.zip
sys-cluster/corosync: version bump fix #572064
Package-Manager: portage-2.2.27
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/corosync/Manifest1
-rw-r--r--sys-cluster/corosync/corosync-2.3.5.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/sys-cluster/corosync/Manifest b/sys-cluster/corosync/Manifest
index dee0a62ad3cb..8a9599f5ca6e 100644
--- a/sys-cluster/corosync/Manifest
+++ b/sys-cluster/corosync/Manifest
@@ -3,3 +3,4 @@ DIST corosync-1.3.5.tar.gz 698897 SHA256 7177914dff0ee16ace7a93f566c4fab06ea7940
DIST corosync-1.4.7.tar.gz 420596 SHA256 89d82641e3ddf28d906b74c7fd220844d617a8415bf5e24802abfbb09acd905f SHA512 275a4372cac13789d93e224e4a7853953d6111afc534f9e897deaf064d5d96bb0db932a02a9212b5a0d2ca53d3f56133073f519460a9ca3573f5403642db34e1 WHIRLPOOL 7b7a2e6c7e032196099dcc827c6b343bb72c803886d005c4dee6ae402f62cc1862a276575edcbb3bbcfa248d51788a6d5953265e0d911cbe9174fd7d64170906
DIST corosync-2.3.3.tar.gz 411784 SHA256 36a13f50e5f653837ab84e91676f001c2aedbc81ea84d3c7e017e740ea6f5a0a SHA512 66b479b2114641f02cd910f1bc3458948d5634b82e2019d7b1ea919f5bbb4817e91dddc33de061ff01dc4f12a3622b3418b7787e81a6f340d23043857cc9442f WHIRLPOOL 0cfdfcebf0956b420b81e6d9e04a12bdfbe639d07f793037f3ab7ee733508a1d48c53a00edcb78fab5700e00db07e150c1b4c12440394f1496d29238ba4615b5
DIST corosync-2.3.4.tar.gz 420184 SHA256 e5e9ee995dfabba4d2347f7d9a5ff85bde1e62f96e1c79dbd7022be2c5b425f4 SHA512 30914552b8af69ce37a5ea98f17a41f30fa01204ca8beee8218d94b8421769504b90c8e62f1e7222afb6429ead8a2d09ca36e71461c767a2b9bf662637f78bb0 WHIRLPOOL 39338ae185c7b97ca33d948f806f720bd9296bbbbff605b1bbd0a2eb6c595c5dee37ebe144d51eca0a049a0d0fa874c93b7110b222adc19008b1469d827be282
+DIST corosync-2.3.5.tar.gz 428253 SHA256 ed8e234f8465d8bb1fbd09a4bca035ef5fd23c249a1278c8398c99e2040c0548 SHA512 212a95d8a68a2941f27c9ec22750a88598744d6fd4db6b46abe0b4cdfa988d3906f760bdf67c403d8c6d0a04da64f29ec744fb68ca51c7269ba58e306553cee9 WHIRLPOOL 7739d932859a1a4552048319d9dbbcb15223f305c236f87c5c4d82cabeb80a53010ab2d42b33a7d8b266c0045bbacd8ba42d452a2b55522f1426693bc669faca
diff --git a/sys-cluster/corosync/corosync-2.3.5.ebuild b/sys-cluster/corosync/corosync-2.3.5.ebuild
new file mode 100644
index 000000000000..93118cf353fe
--- /dev/null
+++ b/sys-cluster/corosync/corosync-2.3.5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+MY_TREE="56ae8fe"
+
+DESCRIPTION="OSI Certified implementation of a complete cluster engine"
+HOMEPAGE="http://www.corosync.org/"
+SRC_URI="https://github.com/corosync/corosync/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc infiniband static-libs systemd xml"
+
+# TODO: support those new configure flags
+# --enable-augeas : Install the augeas lens for corosync.conf
+# --enable-snmp : SNMP protocol support
+# --enable-watchdog : Watchdog support
+RDEPEND="!sys-cluster/heartbeat
+ infiniband? (
+ sys-infiniband/libibverbs:*
+ sys-infiniband/librdmacm:*
+ )
+ dev-libs/nss
+ >=sys-cluster/libqb-0.14.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( sys-apps/groff )"
+
+PATCHES=( "${FILESDIR}/${PN}-2.3.4-docs.patch" )
+
+DOCS=( README.recovery SECURITY AUTHORS )
+
+S="${WORKDIR}/${PN}-${PN}-${MY_TREE}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ default
+ # appends lib to localstatedir automatically
+ # FIXME: install just shared libs --disable-static does not work
+ econf_opts=(
+ --localstatedir=/var \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable infiniband rdma) \
+ $(use_enable systemd) \
+ $(use_enable xml xmlconf)
+ )
+ use doc && econf_opts+=( --enable-doc )
+ econf "${econf_opts[@]}"
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ if use systemd; then
+ rm "${D}"/lib/systemd/system/corosync-notifyd.service || die
+ else
+ rm "${D}"/etc/init.d/corosync-notifyd || die
+ fi
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+
+ keepdir /var/lib/corosync
+ use static-libs || rm -rf "${D}"/usr/$(get_libdir)/*.{,l}a || die
+
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} < 2.0 ]]; then
+ ewarn "!! IMPORTANT !!"
+ ewarn " "
+ ewarn "Migrating from a previous version of corosync can be dangerous !"
+ ewarn " "
+ ewarn "Make sure you backup your cluster configuration before proceeding"
+ ewarn " "
+ fi
+}