summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-03-08 23:04:28 +0000
committerJames Le Cuirot <chewi@gentoo.org>2018-03-08 23:06:13 +0000
commit59dc7fc9ad4d9cd8c00320b5cc74bac4f2e41db5 (patch)
tree3e8fb6c909a7e2bf2a7c33db3a1e1a0ea2d57a31 /sys-cluster
parentsys-cluster/glusterfs: Update 9999 with new silent rules patch (diff)
downloadgentoo-59dc7fc9ad4d9cd8c00320b5cc74bac4f2e41db5.tar.gz
gentoo-59dc7fc9ad4d9cd8c00320b5cc74bac4f2e41db5.tar.bz2
gentoo-59dc7fc9ad4d9cd8c00320b5cc74bac4f2e41db5.zip
sys-cluster/glusterfs: Version bump to 4.0.0
I can't see any announcement about this version yet but it's tagged in git and the source tarball is there. More importantly, it properly fixes the libtirpc issues. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/glusterfs/Manifest1
-rw-r--r--sys-cluster/glusterfs/glusterfs-4.0.0.ebuild224
2 files changed, 225 insertions, 0 deletions
diff --git a/sys-cluster/glusterfs/Manifest b/sys-cluster/glusterfs/Manifest
index 5223b773b139..2534dabde053 100644
--- a/sys-cluster/glusterfs/Manifest
+++ b/sys-cluster/glusterfs/Manifest
@@ -1,2 +1,3 @@
DIST glusterfs-3.12.3.tar.gz 7187644 BLAKE2B 736c6bb408b0bd289ce5ce0abcc7e8bf4b7f96e4e92a1e669f016b59fb16993b17f7cf50fed09a6eeb851b57054c7bf9e595b642c506b0aca567d7ae80de0e84 SHA512 f648b8324a69360b510c947e49918467c969dcc21b6a408b6916b780aa78c44abe027b6c84d696eed7d5f381b055edd3be1dfe4f3ea8f76d15d9319cd08cfa3d
DIST glusterfs-3.13.0.tar.gz 7445713 BLAKE2B 9e03cc9fb214252cb883c1cb0751dbda71d54cf0c8f15f126f6f7a9f1e437cfc7e42df800c01bd4b6916e32005fc93e5d8ff6228810accdba30c30219ab4f878 SHA512 36d89866658ed10b84ba38a1d7f2afd90f1b7fcc5e40f7e8a2c8e1d05e5b282e7f4e9e20dbe64e093b997a05f884563b8b57aef9ed6b17d61400275c3553c5e1
+DIST glusterfs-4.0.0.tar.gz 7632629 BLAKE2B 9367d2c99452d261d889cf564f3a055e1459ee54377cbf8cf6cc46c8d7f153bb258892fb73fc492d1dc6c5bea156d204971256fefc96f9f4825583d9c1086563 SHA512 acd3c462a8e15fb31f4b30d2e217928488e32d66ae7d1061df3e166354a4ddcdeb0ba0bcc994b7563f83376c882800fad07e190e0086fda987915c195266421f
diff --git a/sys-cluster/glusterfs/glusterfs-4.0.0.ebuild b/sys-cluster/glusterfs/glusterfs-4.0.0.ebuild
new file mode 100644
index 000000000000..a4a5bf36143e
--- /dev/null
+++ b/sys-cluster/glusterfs/glusterfs-4.0.0.ebuild
@@ -0,0 +1,224 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools elisp-common python-single-r1 systemd user versionator
+
+if [[ ${PV#9999} != ${PV} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gluster/glusterfs.git"
+else
+ SRC_URI="https://download.gluster.org/pub/gluster/${PN}/$(get_version_component_range '1-2')/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
+HOMEPAGE="https://www.gluster.org/"
+
+LICENSE="|| ( GPL-2 LGPL-3+ )"
+SLOT="0"
+IUSE="bd-xlator crypt-xlator debug emacs +fuse +georeplication glupy infiniband +libtirpc qemu-block rsyslog static-libs +syslog systemtap test +tiering vim-syntax +xml"
+
+REQUIRED_USE="georeplication? ( ${PYTHON_REQUIRED_USE} )
+ glupy? ( ${PYTHON_REQUIRED_USE} )"
+
+# the tests must be run as root
+RESTRICT="test"
+
+# sys-apps/util-linux is required for libuuid
+RDEPEND="bd-xlator? ( sys-fs/lvm2 )
+ !elibc_glibc? ( sys-libs/argp-standalone )
+ emacs? ( virtual/emacs )
+ fuse? ( >=sys-fs/fuse-2.7.0:0 )
+ georeplication? ( ${PYTHON_DEPS} )
+ infiniband? ( sys-fabric/libibverbs:* sys-fabric/librdmacm:* )
+ libtirpc? ( net-libs/libtirpc:= )
+ !libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
+ qemu-block? ( dev-libs/glib:2 )
+ systemtap? ( dev-util/systemtap )
+ tiering? ( dev-db/sqlite:3 )
+ xml? ( dev-libs/libxml2 )
+ sys-libs/readline:=
+ dev-libs/libaio
+ dev-libs/openssl:=[-bindist]
+ dev-libs/userspace-rcu:=
+ net-libs/rpcsvc-proto
+ sys-apps/util-linux"
+DEPEND="${RDEPEND}
+ virtual/acl
+ virtual/pkgconfig
+ sys-devel/bison
+ sys-devel/flex
+ test? ( >=dev-util/cmocka-1.0.1
+ app-benchmarks/dbench
+ dev-vcs/git
+ net-fs/nfs-utils
+ virtual/perl-Test-Harness
+ dev-libs/yajl
+ sys-fs/xfsprogs
+ sys-apps/attr )"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.12.2-poisoned-sysmacros.patch"
+ "${FILESDIR}/${PN}-3.12.2-silent_rules.patch"
+)
+
+DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
+
+# Maintainer notes:
+# * The build system will always configure & build argp-standalone but it'll never use it
+# if the argp.h header is found in the system. Which should be the case with
+# glibc or if argp-standalone is installed.
+
+pkg_setup() {
+ python_setup "python2*"
+ python-single-r1_pkg_setup
+
+ # Needed for statedumps
+ # https://github.com/gluster/glusterfs/commit/0e50c4b3ea734456c14e2d7a578463999bd332c3
+ enewgroup gluster
+ enewuser gluster -1 -1 "${EPREFIX}"/var/run/gluster gluster
+}
+
+src_prepare() {
+ default
+
+ # build rpc-transport and xlators only once as shared libs
+ find rpc/rpc-transport xlators -name Makefile.am |
+ xargs sed -i 's|.*$(top_srcdir).*\.sym|\0 -shared|' || die
+
+ # fix execution permissions
+ chmod +x libglusterfs/src/gen-defaults.py || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-silent-rules \
+ --disable-fusermount \
+ $(use_enable debug) \
+ $(use_enable bd-xlator) \
+ $(use_enable crypt-xlator) \
+ $(use_enable fuse fuse-client) \
+ $(use_enable georeplication) \
+ $(use_enable glupy) \
+ $(use_enable infiniband ibverbs) \
+ $(use_enable qemu-block) \
+ $(use_enable static-libs static) \
+ $(use_enable syslog) \
+ $(use_enable systemtap) \
+ $(use_enable test cmocka) \
+ $(use_enable tiering) \
+ $(use_enable xml xml-output) \
+ $(use_with libtirpc ipv6-default) \
+ $(use_with libtirpc) \
+ --with-tmpfilesdir="${EPREFIX}"/etc/tmpfiles.d \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ default
+ use emacs && elisp-compile extras/glusterfs-mode.el
+}
+
+src_install() {
+ default
+
+ rm \
+ "${ED}"/etc/glusterfs/glusterfs-{georep-,}logrotate \
+ "${ED}"/etc/glusterfs/gluster-rsyslog-*.conf \
+ "${ED}"/usr/share/doc/${PF}/glusterfs{-mode.el,.vim} || die "removing false files failed"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/glusterfs.logrotate glusterfs
+
+ if use rsyslog ; then
+ insinto /etc/rsyslog.d
+ newins extras/gluster-rsyslog-7.2.conf 60-gluster.conf
+ fi
+
+ if use emacs ; then
+ elisp-install ${PN} extras/glusterfs-mode.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}"/${PN}.vim
+ insinto /usr/share/vim/vimfiles/syntax; doins extras/${PN}.vim
+ fi
+
+ # insert some other tools which might be useful
+ insinto /usr/share/glusterfs/scripts
+ doins \
+ extras/backend-{cleanup,xattr-sanitize}.sh \
+ extras/clear_xattrs.sh \
+ extras/migrate-unify-to-distribute.sh
+
+ # correct permissions on installed scripts
+ # fperms 0755 /usr/share/glusterfs/scripts/*.sh
+ chmod 0755 "${ED}"/usr/share/glusterfs/scripts/*.sh || die
+
+ if use georeplication ; then
+ # move the gsync-sync-gfid tool to a binary path
+ # and set a symlink to be compliant with all other distros
+ mv "${ED}"/usr/{share/glusterfs/scripts/gsync-sync-gfid,libexec/glusterfs/} || die
+ dosym ../../../libexec/glusterfs/gsync-sync-gfid /usr/share/glusterfs/scripts/gsync-sync-gfid
+ fi
+
+ newinitd "${FILESDIR}/${PN}-r1.initd" glusterfsd
+ newinitd "${FILESDIR}/glusterd-r3.initd" glusterd
+ newconfd "${FILESDIR}/${PN}.confd" glusterfsd
+
+ keepdir /var/log/${PN}
+ keepdir /var/lib/glusterd/{events,glusterfind/.keys}
+
+ # QA
+ rm -r "${ED}/var/run/" || die
+ if ! use static-libs; then
+ find "${D}" -type f -name '*.la' -delete || die
+ fi
+
+ # fix all shebang for python2 #560750
+ python_fix_shebang "${ED}"
+}
+
+src_test() {
+ ./run-tests.sh || die
+}
+
+pkg_postinst() {
+ elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
+ elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
+ elog " /etc/init.d/glusterd start"
+ echo
+ elog "For static configurations, the glusterfsd startup script can be multiplexed."
+ elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
+ elog "separate service. To create additional instances of the glusterfsd service"
+ elog "simply create a symlink to the glusterfsd startup script."
+ echo
+ elog "Example:"
+ elog " # ln -s glusterfsd /etc/init.d/glusterfsd2"
+ elog " # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
+ elog "You can now treat glusterfsd2 like any other service"
+ echo
+ ewarn "You need to use a ntp client to keep the clocks synchronized across all"
+ ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
+ ewarn "run GlusterFS."
+ echo
+ elog "If you are upgrading from a previous version of ${PN}, please read:"
+ elog " http://docs.gluster.org/en/latest/Upgrade-Guide/upgrade_to_$(get_version_component_range '1-2')/"
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}