summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-29 18:31:34 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-29 18:31:34 +0200
commit7bb0c6747b5e76689162f34f913619371eba0942 (patch)
treec254fad2af7a14c0b4c6f85eae951c1a411ab414 /sys-cluster
parentapp-i18n/scim-pinyin: Port to EAPI 7 (diff)
downloadgentoo-7bb0c6747b5e76689162f34f913619371eba0942.tar.gz
gentoo-7bb0c6747b5e76689162f34f913619371eba0942.tar.bz2
gentoo-7bb0c6747b5e76689162f34f913619371eba0942.zip
sys-cluster/classads: Port to EAPI 7
Closes: https://bugs.gentoo.org/725790 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/classads/classads-1.0.10.ebuild28
1 files changed, 20 insertions, 8 deletions
diff --git a/sys-cluster/classads/classads-1.0.10.ebuild b/sys-cluster/classads/classads-1.0.10.ebuild
index 72ea735ea47f..4b692bd26e3e 100644
--- a/sys-cluster/classads/classads-1.0.10.ebuild
+++ b/sys-cluster/classads/classads-1.0.10.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools-utils
+EAPI=7
+
+inherit autotools
DESCRIPTION="Condor's classified advertisement language"
HOMEPAGE="http://www.cs.wisc.edu/condor/classad/"
@@ -11,15 +12,26 @@ SRC_URI="ftp://ftp.cs.wisc.edu/condor/classad/c++/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="pcre static-libs"
+IUSE="pcre"
RDEPEND="pcre? ( dev-libs/libpcre )"
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
- myeconfargs+=(
- --enable-namespace
+ econf \
+ --disable-static \
+ --enable-namespace \
--enable-flexible-member
- )
- autotools-utils_src_configure
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}