summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-02-28 11:50:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-02-28 11:51:04 +0000
commit7c36b2d7261ec57264ece4d1c6724c86f4785b9e (patch)
tree3e18db4d16a6f1a6a9fb3634bf85cc3147cca77c /sys-cluster
parentmedia-sound/musescore: fixed compilation with -mp3 (diff)
downloadgentoo-7c36b2d7261ec57264ece4d1c6724c86f4785b9e.tar.gz
gentoo-7c36b2d7261ec57264ece4d1c6724c86f4785b9e.tar.bz2
gentoo-7c36b2d7261ec57264ece4d1c6724c86f4785b9e.zip
sys-cluster/ucx: Add 1.10.0_rc5
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ucx/Manifest1
-rw-r--r--sys-cluster/ucx/ucx-1.10.0_rc5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-cluster/ucx/Manifest b/sys-cluster/ucx/Manifest
index 6fe2cc8d421a..68892672ea6a 100644
--- a/sys-cluster/ucx/Manifest
+++ b/sys-cluster/ucx/Manifest
@@ -1,3 +1,4 @@
+DIST ucx-1.10.0_rc5.tar.gz 2399950 BLAKE2B f6f78d2a3e0cd7f252354d59b9d667992c5f9f4d8ee4a41356decf4a1ed72382d8ce5213395bc6bacf1d8658f95808082cc0f825230857ddbbff19ed060efa5c SHA512 b772ad030e80bc5b0ab25d590117950d363f5f7ea1b7ed5ce0bba285d0a932205ee4d73705c094cef077c751b1cf8b6efdd4608c7df6b39d813771a0a31460ac
DIST ucx-1.2.2.tar.gz 1513611 BLAKE2B 488b9b3cecc2c617b1209036e1342e4378459db6a5e93eab1d88dfe80cb0d9c8013c767413206f0fbd0105557ed89994ab510421068d709101336a7b3d2eac5e SHA512 515c382826310b9aa7179ab19ceb76a881a41e6786514219b7f703c6144fa57ca141bceb3b80523ae1b4e2a4b13e9abcb9df063612b376d894c5cd81cdc00571
DIST ucx-1.3.0.tar.gz 1707317 BLAKE2B 740ab240663a26fde8abe631416dae6233febf3c587ba6bb7b27a9cb0aa041540ce71e106bb3c5618a719de66d479055961908b67125df61a4c7696999c0affb SHA512 0a2e32985e0225fc4ad15dbb1c422dba1d5552638e7329d67572924502e61e1a481ce30cde5ccc83c663fb4ec643df83efc08aed164dfbce6cf38d66a16b3e42
DIST ucx-1.5.2.tar.gz 1844416 BLAKE2B 2e0296e34d8116a79c545fb3371dda1746517a18cc75f94da5d1f9420c7a74752839d5a3a07a61a2e91021baa87a26d02ab24554316351db9ba76721a18a5244 SHA512 7f11014eb26df342fc8f0914d323f08f4c19ea21e98e18f0a4ec18b7004299687f91daa8ee654ecee716ece6d4d6de5c9714c548768b1d44551b6be6195e2e9b
diff --git a/sys-cluster/ucx/ucx-1.10.0_rc5.ebuild b/sys-cluster/ucx/ucx-1.10.0_rc5.ebuild
new file mode 100644
index 000000000000..1d3c4a64a113
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.10.0_rc5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="https://www.openucx.org"
+
+MY_PV=${PV/_/-}
+SRC_URI="https://github.com/openucx/ucx/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+numa +openmp"
+
+RDEPEND="
+ sys-libs/binutils-libs:=
+ numa? ( sys-process/numactl )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ BASE_CFLAGS="" \
+ econf \
+ --disable-compiler-opt \
+ $(use_enable numa) \
+ $(use_enable openmp)
+}
+
+src_compile() {
+ BASE_CFLAGS="" emake
+}