summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-07-09 15:50:58 +0100
committerJustin Lecher <jlec@gentoo.org>2017-07-09 19:48:30 +0100
commit7c939e7a1b163ab5a754ba6592067be14ed9158c (patch)
tree50b7fbdc22f1da1dba4415b032ff89bc5e516566 /sys-cluster
parentx11-libs/vte: ia64 stable, bug #624312 (diff)
downloadgentoo-7c939e7a1b163ab5a754ba6592067be14ed9158c.tar.gz
gentoo-7c939e7a1b163ab5a754ba6592067be14ed9158c.tar.bz2
gentoo-7c939e7a1b163ab5a754ba6592067be14ed9158c.zip
sys-cluster/slurm: Fix compilation error with glibc-2.25
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=617192 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/slurm/files/slurm-16.05.2-sysmacros.patch34
-rw-r--r--sys-cluster/slurm/slurm-16.05.2.ebuild5
2 files changed, 37 insertions, 2 deletions
diff --git a/sys-cluster/slurm/files/slurm-16.05.2-sysmacros.patch b/sys-cluster/slurm/files/slurm-16.05.2-sysmacros.patch
new file mode 100644
index 000000000000..f9d22f479f89
--- /dev/null
+++ b/sys-cluster/slurm/files/slurm-16.05.2-sysmacros.patch
@@ -0,0 +1,34 @@
+ configure.ac | 2 +-
+ src/plugins/task/cgroup/task_cgroup_devices.c | 6 ++++++
+ 2 files changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 869a989..2936983 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -141,7 +141,7 @@ AC_CHECK_HEADERS(mcheck.h values.h socket.h sys/socket.h \
+ AC_HEADER_SYS_WAIT
+ AC_HEADER_TIME
+ AC_HEADER_STDC
+-
++AC_HEADER_MAJOR
+
+ dnl Checks for structures.
+ dnl
+diff --git a/src/plugins/task/cgroup/task_cgroup_devices.c b/src/plugins/task/cgroup/task_cgroup_devices.c
+index 554583c..9be99d8 100644
+--- a/src/plugins/task/cgroup/task_cgroup_devices.c
++++ b/src/plugins/task/cgroup/task_cgroup_devices.c
+@@ -42,6 +42,12 @@
+ #include <sched.h>
+ #include <glob.h>
+ #include <sys/types.h>
++#ifdef MAJOR_IN_MKDEV
++# include <sys/mkdev.h>
++#endif
++#ifdef MAJOR_IN_SYSMACROS
++# include <sys/sysmacros.h>
++#endif
+ #include <sys/stat.h>
+ #include <slurm/slurm.h>
+ #include <slurm/slurm_errno.h>
diff --git a/sys-cluster/slurm/slurm-16.05.2.ebuild b/sys-cluster/slurm/slurm-16.05.2.ebuild
index 2561857e107a..9e0f02d6bbf4 100644
--- a/sys-cluster/slurm/slurm-16.05.2.ebuild
+++ b/sys-cluster/slurm/slurm-16.05.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -53,7 +53,8 @@ LIBSLURMDB_PERL_S="${WORKDIR}/${P}/contribs/perlapi/libslurmdb/perl"
RESTRICT="primaryuri"
PATCHES=(
- "${FILESDIR}/${P}-disable-sview.patch"
+ "${FILESDIR}"/${P}-disable-sview.patch
+ "${FILESDIR}"/${P}-sysmacros.patch
)
src_unpack() {