summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-11-29 23:14:40 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-11-29 23:18:10 -0600
commit9f8e1e313a3ed7e4d7ea2b0f2052ff7745fc7e0f (patch)
treeb5c64800b575d6a984545c56ae0dd8742570d421 /sys-cluster
parentsys-auth/keystone: switch fully to python_install_all (diff)
downloadgentoo-9f8e1e313a3ed7e4d7ea2b0f2052ff7745fc7e0f.tar.gz
gentoo-9f8e1e313a3ed7e4d7ea2b0f2052ff7745fc7e0f.tar.bz2
gentoo-9f8e1e313a3ed7e4d7ea2b0f2052ff7745fc7e0f.zip
sys-cluster/neutron: switch most to python_install_all
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/neutron/neutron-2016.2.9999.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/sys-cluster/neutron/neutron-2016.2.9999.ebuild b/sys-cluster/neutron/neutron-2016.2.9999.ebuild
index 92c35823b9e6..5f78ccc3e21f 100644
--- a/sys-cluster/neutron/neutron-2016.2.9999.ebuild
+++ b/sys-cluster/neutron/neutron-2016.2.9999.ebuild
@@ -128,7 +128,7 @@ RDEPEND="
#PATCHES=(
#)
-pkg_setup() {
+pkg_pretend() {
linux-info_pkg_setup
CONFIG_CHECK_MODULES="VLAN_8021Q IP6_NF_FILTER IP6_NF_IPTABLES IP_NF_TARGET_REJECT \
IP_NF_MANGLE IP_NF_TARGET_MASQUERADE NF_NAT_IPV4 NF_CONNTRACK_IPV4 NF_DEFRAG_IPV4 \
@@ -138,6 +138,9 @@ pkg_setup() {
linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled in kernel"
done
fi
+}
+
+pkg_setup() {
enewgroup neutron
enewuser neutron -1 -1 /var/lib/neutron neutron
}
@@ -154,8 +157,8 @@ src_prepare() {
distutils-r1_python_prepare_all
}
-python_install() {
- distutils-r1_python_install
+python_install_all() {
+ distutils-r1_python_install_all
if use server; then
newinitd "${FILESDIR}/neutron.initd" "neutron-server"
newconfd "${FILESDIR}/neutron-server.confd" "neutron-server"
@@ -197,10 +200,6 @@ python_install() {
doins "etc/rootwrap.conf"
doins -r "etc/neutron/rootwrap.d"
- insopts -m 0644
- insinto "/usr/lib64/python2.7/site-packages/neutron/db/migration/alembic_migrations/"
- doins -r "neutron/db/migration/alembic_migrations/versions"
-
#add sudoers definitions for user neutron
insinto /etc/sudoers.d/
insopts -m 0440 -o root -g root
@@ -220,6 +219,14 @@ python_install() {
rm -R "${D}/usr/etc/"
}
+python_install() {
+ distutils-r1_python_install
+ # copy migration conf file (not coppied on install via setup.py script)
+ insopts -m 0644
+ insinto "/$(python_get_sitedir)/neutron/db/migration/alembic_migrations/"
+ doins -r "neutron/db/migration/alembic_migrations/versions"
+}
+
pkg_postinst() {
elog
elog "neutron-server's conf.d file may need updating to include additional ini files"