summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-02-08 22:13:02 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-02-18 10:24:50 +0200
commitae62b55b2b62e1609117b1285895903a236d2d2c (patch)
treec84ff77f62d8f86c3516151c0424cd89d5f483c0 /sys-cluster
parentsys-cluster/charliecloud: Bump to version 0.22. (diff)
downloadgentoo-ae62b55b2b62e1609117b1285895903a236d2d2c.tar.gz
gentoo-ae62b55b2b62e1609117b1285895903a236d2d2c.tar.bz2
gentoo-ae62b55b2b62e1609117b1285895903a236d2d2c.zip
sys-cluster/charliecloud: Drop old.
This also removes an unused local USE flag. Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Closes: https://github.com/gentoo/gentoo/pull/19379 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.20.ebuild80
-rw-r--r--sys-cluster/charliecloud/metadata.xml1
3 files changed, 0 insertions, 82 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index 357e836f68fb..da23cb4e98f3 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1,3 +1,2 @@
-DIST charliecloud-0.20.tar.gz 372770 BLAKE2B a5e6ad3fc93aa7219ec8d35ae112fc7320befc909d2cc805f5d67a356840112c245581c18d790a4fc755e70240e6444059cab8b9531eaedb3e3b941cf756aa55 SHA512 e3269bbf667462214ba88f8fc4651396c9621cd315a798113b66e8be0d4367ce1c18b8b956f325bd07049d644b46fd6837c5b712ced4bdf20a42bcc9aaafd8b7
DIST charliecloud-0.21.tar.gz 386637 BLAKE2B a5b115a9d741a2c83596a302e7dd3d0d6096eb11f3e38925009b05f5a16f2d6fa4ff1c0023789feae1d359c94e4970dcc62d597437c6f7143f8152603b0e9a88 SHA512 89351e4dc039cd724c7503a4855f0980128d28aa4e2e98c5fd8cc5060e2c853e65280b830526691c8d4c7d85168658d578236893075637e3a38c6eb1df4e8dfe
DIST charliecloud-0.22.tar.gz 402106 BLAKE2B 4c2d4bf77424c5b46e5593bc28bbe10891c353c23c8d382a9ca7515187538f5fef4d90b95f34572f65223f27433ccab9021bf9e4bc31931787894924d1dd02e2 SHA512 c528ffa9ecddbd4a26b0a8b6cc593340f3aaa0911cf45e1f6a5fe860178917f069ca9b31b7c1aee6220762bbe4b75114219eac4cdd3987bcb3f3338e2b6fb18e
diff --git a/sys-cluster/charliecloud/charliecloud-0.20.ebuild b/sys-cluster/charliecloud/charliecloud-0.20.ebuild
deleted file mode 100644
index 70ef80763985..000000000000
--- a/sys-cluster/charliecloud/charliecloud-0.20.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit autotools optfeature python-single-r1
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
- S="${WORKDIR}/${P}"
-else
- SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~x86-linux"
-fi
-
-DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
-HOMEPAGE="https://hpc.github.io/charliecloud/"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-IUSE="ch-grow doc"
-
-# Extensive test suite exists, but downloads container images
-# directly and via Docker and installs packages inside using apt/yum.
-# Additionally, clashes with portage namespacing and sandbox.
-RESTRICT="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="
- ch-grow? (
- $(python_gen_cond_dep '
- dev-python/lark-parser[${PYTHON_MULTI_USEDEP}]
- dev-python/requests[${PYTHON_MULTI_USEDEP}]
- ')
- )
- doc? (
- $(python_gen_cond_dep '
- dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_MULTI_USEDEP}]
- ')
- net-misc/rsync
- )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local econf_args=()
- econf_args+=(
- $(use_enable doc html)
- $(use_enable ch-grow)
- # Libdir is used as a libexec-style destination.
- --libdir="${EPREFIX}"/usr/lib
- # Attempts to call python-exec directly otherwise.
- --with-sphinx-python=${PYTHON}
- # This disables -Werror, see also: https://github.com/hpc/charliecloud/pull/808
- --enable-buggy-build
- )
- econf "${econf_args[@]}"
-}
-
-pkg_postinst() {
- elog "Various builders are supported, as alternative "
- elog "to the internal ch-grow. The following packages "
- elog "can be installed to get the corresponding support "
- elog "and related functionality."
-
- optfeature "Building with Buildah" app-emulation/buildah
- optfeature "Building with Docker" app-emulation/docker
- optfeature "Progress bars during long operations" sys-apps/pv
- optfeature "Pack and unpack squashfs images" sys-fs/squashfs-tools
- optfeature "Mount and umount squashfs images" sys-fs/squashfuse
-}
diff --git a/sys-cluster/charliecloud/metadata.xml b/sys-cluster/charliecloud/metadata.xml
index 0e5ccf0b73ee..b580309d72a1 100644
--- a/sys-cluster/charliecloud/metadata.xml
+++ b/sys-cluster/charliecloud/metadata.xml
@@ -14,6 +14,5 @@
</upstream>
<use>
<flag name='ch-image'>Build the internal builder ch-image (previously named ch-grow)</flag>
- <flag name='ch-grow'>Build the internal builder ch-grow</flag>
</use>
</pkgmetadata>