summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-01 01:31:14 +0200
committerSam James <sam@gentoo.org>2022-06-01 01:17:37 +0100
commitb4ec8c54b1a4fab045c0e26c565465de9e2d0c05 (patch)
treefe3c03d8c817cb96697d669a32bfd27078fe6c94 /sys-cluster
parentgames-action/polymc: remove some troublesome compile flags (diff)
downloadgentoo-b4ec8c54b1a4fab045c0e26c565465de9e2d0c05.tar.gz
gentoo-b4ec8c54b1a4fab045c0e26c565465de9e2d0c05.tar.bz2
gentoo-b4ec8c54b1a4fab045c0e26c565465de9e2d0c05.zip
sys-cluster/kronosnet: remove -Werror
Closes: https://bugs.gentoo.org/781626 Closes: https://bugs.gentoo.org/750548 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24841 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/kronosnet/files/kronosnet-1.19-no-Werror.patch11
-rw-r--r--sys-cluster/kronosnet/kronosnet-1.19-r1.ebuild57
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-cluster/kronosnet/files/kronosnet-1.19-no-Werror.patch b/sys-cluster/kronosnet/files/kronosnet-1.19-no-Werror.patch
new file mode 100644
index 000000000000..a53d637f2525
--- /dev/null
+++ b/sys-cluster/kronosnet/files/kronosnet-1.19-no-Werror.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -307,7 +307,7 @@
+ GDB_FLAGS="-g"
+ fi
+
+-DEFAULT_CFLAGS="-Werror -Wall -Wextra"
++DEFAULT_CFLAGS="-Wall -Wextra"
+
+ # manual overrides
+ # generates too much noise for stub APIs
diff --git a/sys-cluster/kronosnet/kronosnet-1.19-r1.ebuild b/sys-cluster/kronosnet/kronosnet-1.19-r1.ebuild
new file mode 100644
index 000000000000..6ca8e8f2a526
--- /dev/null
+++ b/sys-cluster/kronosnet/kronosnet-1.19-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Network abstraction layer designed for High Availability use cases"
+HOMEPAGE="https://kronosnet.org"
+SRC_URI="https://kronosnet.org/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="doc nss +openssl zstd lz4 lzo2"
+
+DEPEND=">=sys-cluster/libqb-2.0.0:=
+ dev-libs/libnl:3
+ sys-libs/zlib:=
+ app-arch/bzip2:=
+ app-arch/xz-utils
+ zstd? ( app-arch/zstd:= )
+ lzo2? ( dev-libs/lzo:2 )
+ lz4? ( app-arch/lz4:= )
+ nss? ( dev-libs/nss )
+ openssl? ( dev-libs/openssl:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ doc? (
+ >=sys-cluster/libqb-2.0.0
+ app-doc/doxygen[dot]
+ )"
+
+PATCHES=( "${FILESDIR}/${P}-no-Werror.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf_opts=(
+ $(use_enable doc man) \
+ --disable-static \
+ --enable-libnozzle \
+ --disable-libknet-sctp \
+ --enable-compress-zlib \
+ --enable-compress-bzip2 \
+ --enable-compress-lzma \
+ $(use_enable nss crypto-nss) \
+ $(use_enable openssl crypto-openssl) \
+ $(use_enable zstd compress-zstd) \
+ $(use_enable lz4 compress-lz4) \
+ $(use_enable lzo2 compress-lzo2)
+ )
+ econf "${econf_opts[@]}"
+}