summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-08-13 21:04:00 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-08-13 21:04:18 -0500
commitb9aa98c4381749d28abc67fad2dc55af145a3264 (patch)
treefd415460e8e1c6d63fce382651d3eb3e9b5ea791 /sys-cluster
parentdev-db/postgresql: Version Bumps (diff)
downloadgentoo-b9aa98c4381749d28abc67fad2dc55af145a3264.tar.gz
gentoo-b9aa98c4381749d28abc67fad2dc55af145a3264.tar.bz2
gentoo-b9aa98c4381749d28abc67fad2dc55af145a3264.zip
sys-cluster/nomad: 0.12.3 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/nomad/Manifest1
-rw-r--r--sys-cluster/nomad/nomad-0.12.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-cluster/nomad/Manifest b/sys-cluster/nomad/Manifest
index bd2b94e28449..a9f60d910a4d 100644
--- a/sys-cluster/nomad/Manifest
+++ b/sys-cluster/nomad/Manifest
@@ -1 +1,2 @@
DIST nomad-0.12.1.tar.gz 51227967 BLAKE2B 1354641dfcfd4d3fca44261792f65ca117be77aaf0d5a028e424b5ced2c14c1cc5e82a8dcac587c3fcb7796e8e260bee8b65fcf202ddd3b766f96373e996a874 SHA512 cbb6b2b89f4922108d10c832638460ad2b234fdfd95e61aa57fb5d89f9852dca1a42527bfd7cbcb166916394b38d7d6451c8f5fd2e56b02599926209e395d9e2
+DIST nomad-0.12.3.tar.gz 51432205 BLAKE2B 77090f387e25f226c8d05b6ea16abfac0f4b710a40a3e7e5455bd6c8b7992080980967d4ebb92257348968dddbb45d2e5c3b58f143ae1205742bf08f0dec2a71 SHA512 17d361db11104ddbbae12a17301005c8eca3650e3fdda8f2fd6db8474728f31a2b6f828f2fba7e7d9d132b08cfb070799273353a17f5f66baa4dc5a0492562f8
diff --git a/sys-cluster/nomad/nomad-0.12.3.ebuild b/sys-cluster/nomad/nomad-0.12.3.ebuild
new file mode 100644
index 000000000000..52e0d90e0b58
--- /dev/null
+++ b/sys-cluster/nomad/nomad-0.12.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module systemd
+GIT_COMMIT=ef99996f1419334e1d9d23eba9d24e7d9404218f
+
+DESCRIPTION="A simple and flexible workload orchestrator "
+HOMEPAGE="https://nomadproject.io"
+SRC_URI="https://github.com/hashicorp/nomad/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_compile() {
+ local go_ldflags go_tags
+ go_ldflags="-X github.com/hashicorp/nomad/version.GitCommit=${GIT_COMMIT}"
+ go_tags="codegen_generated"
+ CGO_ENABLED=1 \
+ go build \
+ -trimpath \
+ -ldflags "${go_ldflags}" \
+ -mod=vendor \
+ -tags "${go_tags}" \
+ -o bin/${PN} || die "compile failed"
+}
+
+src_install() {
+ dobin bin/${PN}
+ systemd_dounit dist/systemd/nomad.service
+ insinto /etc/nomad.d
+ newins dist/client.hcl client.hcl.example
+ newins dist/server.hcl server.hcl.example
+ keepdir /var/lib/nomad /var/log/nomad
+ newconfd "${FILESDIR}/nomad.confd" nomad
+ newinitd "${FILESDIR}/nomad.initd" nomad
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/nomad.logrotated" nomad
+}