summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-06-30 17:10:44 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-06-30 17:11:25 -0700
commitc390511f04d842685ab2c0b45759e4daae782f24 (patch)
treebf08482cb95d079d619f777c9678af2d535bbde7 /sys-cluster
parentdev-util/qbs: add 1.16.0 (diff)
downloadgentoo-c390511f04d842685ab2c0b45759e4daae782f24.tar.gz
gentoo-c390511f04d842685ab2c0b45759e4daae782f24.tar.bz2
gentoo-c390511f04d842685ab2c0b45759e4daae782f24.zip
sys-cluster/ceph: Bump to 15.2.4, cleanups to 14.2.10
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/Manifest2
-rw-r--r--sys-cluster/ceph/ceph-14.2.10.ebuild16
-rw-r--r--sys-cluster/ceph/ceph-15.2.4.ebuild (renamed from sys-cluster/ceph/ceph-15.2.3.ebuild)19
3 files changed, 19 insertions, 18 deletions
diff --git a/sys-cluster/ceph/Manifest b/sys-cluster/ceph/Manifest
index 8c2cc97fb017..494ff52007c5 100644
--- a/sys-cluster/ceph/Manifest
+++ b/sys-cluster/ceph/Manifest
@@ -1,4 +1,4 @@
DIST ceph-12.2.12.tar.gz 77467762 BLAKE2B a5224432121db9ef49c1e22771d847399df2f7881cd9c2e185eca12096efb79d21578659d248eb5bae678924983d57452d370e23ab7e78663764d7bea834a461 SHA512 e694c9a8c1f9836c08fb74b54423bdc16d4900252e34643c56cf1a615d4dacddfb13df06a6a9f68bb9d438f5f07069ed358f9fa4b5a362640a3046f9c7722dcc
DIST ceph-14.2.10.tar.gz 129274835 BLAKE2B b3f14897db478418b982281bf367a0c497cdfa8991a73e277b5582663c159550f3eff5bdc78a506e267eae8d59c59b19b8a9294802cb532fd7dfa9f612ed0e53 SHA512 5ec95b933a360183f89404446c5e1912a81853dfb1134bb8868bc6675a0185420c2bf1eba72308014a008f617aeb8733d51eb8c8eea5d472c32514cf483f4ea6
DIST ceph-14.2.9.tar.gz 128419205 BLAKE2B bace7469d9066a3da7320a0eb894013fae5b7139c15679dddae7df28c593a1029956234a1ba0d3bbdf1639e3a975aa776c695efefb915113a16099c80d563675 SHA512 0a26372d0037c32fe1d24be880e272fcce5089b02adfb0e791e0406155f6e66c913fa43762028f49c1fa3f30c6c8d819c521dd11702a37cc7040dfd3097c068e
-DIST ceph-15.2.3.tar.gz 147807898 BLAKE2B ff5e9707cf05e22af718ee177cce87ea9913b1b78d7ba17589f2c7fdaea0a7a27dd1f7b8e9947a095ed74106b6b19258fd8be259100624032f3a6e8ce5243390 SHA512 0378365863bcb86e62d64a2eff91e39a91218eabfb126dae74185e1fe52b21a3d5113f885ddb8076551f2f069435e18b24417bf70f29f23e21fac7065e412912
+DIST ceph-15.2.4.tar.gz 148011928 BLAKE2B c0222725227cf922ed10bb19840b8cbfe0c0b8ae77a4f83f03a95c3fc198165740f7a1dee5e1983e9403634ce389c858e71ed3f2731202630e19961a5de0247a SHA512 94e9b4c87d9f27dbfc9961b853f2cf159d65b614bf50ac3dabad9d801a181c547550ab4bca1f48c7a6e11aa6188e5858b110a9023dc214a043ed5ba375b3dee2
diff --git a/sys-cluster/ceph/ceph-14.2.10.ebuild b/sys-cluster/ceph/ceph-14.2.10.ebuild
index b9bca5dfb763..f335155f0e1e 100644
--- a/sys-cluster/ceph/ceph-14.2.10.ebuild
+++ b/sys-cluster/ceph/ceph-14.2.10.ebuild
@@ -7,9 +7,8 @@ CMAKE_MAKEFILE_GENERATOR=emake
DISTUTILS_OPTIONAL=1
-inherit check-reqs bash-completion-r1 cmake-utils distutils-r1 flag-o-matic \
- multiprocessing python-r1 udev readme.gentoo-r1 toolchain-funcs \
- systemd tmpfiles
+inherit check-reqs bash-completion-r1 cmake distutils-r1 flag-o-matic \
+ python-r1 udev readme.gentoo-r1 toolchain-funcs systemd tmpfiles
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -175,7 +174,7 @@ RESTRICT="test? ( userpriv )"
RESTRICT+=" test"
# false positives unless all USE flags are on
-CMAKE_WARN_UNUSED_CLI="no"
+CMAKE_WARN_UNUSED_CLI=no
PATCHES=(
"${FILESDIR}/ceph-12.2.0-use-provided-cpu-flag-values.patch"
@@ -192,6 +191,7 @@ PATCHES=(
"${FILESDIR}/ceph-14.2.4-python-executable.patch"
"${FILESDIR}/ceph-14.2.4-undefined-behaviour.patch"
"${FILESDIR}/ceph-14.2.10-missing-includes.patch"
+ "${FILESDIR}/ceph-14.2.10-python-warnings.patch"
)
check-reqs_export_vars() {
@@ -213,7 +213,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if use system-boost; then
find "${S}" -name '*.cmake' -or -name 'CMakeLists.txt' -print0 \
@@ -281,7 +281,7 @@ ceph_src_configure() {
rm -f "${BUILD_DIR:-${S}}/CMakeCache.txt" \
|| die "failed to remove cmake cache"
- cmake-utils_src_configure
+ cmake_src_configure
# bug #630232
sed -i "s:\"${T//:\\:}/${EPYTHON}/bin/python\":\"${PYTHON}\":" \
@@ -309,7 +309,7 @@ python_compile() {
}
src_compile() {
- cmake-utils_src_make VERBOSE=1 all
+ cmake_build VERBOSE=1 all
# we have to do this here to prevent from building everything multiple times
python_copy_sources
@@ -330,7 +330,7 @@ python_install() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
python_foreach_impl python_install
find "${ED}" -name '*.la' -type f -delete || die
diff --git a/sys-cluster/ceph/ceph-15.2.3.ebuild b/sys-cluster/ceph/ceph-15.2.4.ebuild
index 49968eb700f0..dc446889a8fc 100644
--- a/sys-cluster/ceph/ceph-15.2.3.ebuild
+++ b/sys-cluster/ceph/ceph-15.2.4.ebuild
@@ -7,9 +7,8 @@ CMAKE_MAKEFILE_GENERATOR=emake
DISTUTILS_OPTIONAL=1
-inherit check-reqs bash-completion-r1 cmake-utils distutils-r1 flag-o-matic \
- multiprocessing python-r1 udev readme.gentoo-r1 toolchain-funcs \
- systemd tmpfiles
+inherit check-reqs bash-completion-r1 cmake distutils-r1 flag-o-matic \
+ python-r1 udev readme.gentoo-r1 toolchain-funcs systemd tmpfiles
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -180,7 +179,7 @@ RESTRICT="test? ( userpriv )"
RESTRICT+=" test"
# false positives unless all USE flags are on
-CMAKE_WARN_UNUSED_CLI="no"
+CMAKE_WARN_UNUSED_CLI=no
PATCHES=(
"${FILESDIR}/ceph-12.2.0-use-provided-cpu-flag-values.patch"
@@ -195,6 +194,7 @@ PATCHES=(
"${FILESDIR}/ceph-15.2.0-rocksdb-cmake.patch"
"${FILESDIR}/ceph-15.2.2-systemd-unit.patch"
"${FILESDIR}/ceph-15.2.3-spdk-compile.patch"
+ "${FILESDIR}/ceph-14.2.10-python-warnings.patch"
)
check-reqs_export_vars() {
@@ -216,12 +216,12 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if use system-boost; then
find "${S}" -name '*.cmake' -or -name 'CMakeLists.txt' -print0 \
| xargs --null sed -r \
- -e 's|Boost::|Boost_|g' \
+ -e 's|Boost::|boost_|g' \
-e 's|Boost_|boost_|g' \
-e 's|[Bb]oost_boost|boost_system|g' -i || die
fi
@@ -276,6 +276,7 @@ ceph_src_configure() {
-DEPYTHON_VERSION="${EPYTHON#python}"
-DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PN}-${PVR}"
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
+ -Wno-dev
)
if use amd64 || use x86; then
for flag in ${CPU_FLAGS_X86[@]}; do
@@ -286,7 +287,7 @@ ceph_src_configure() {
rm -f "${BUILD_DIR:-${S}}/CMakeCache.txt" \
|| die "failed to remove cmake cache"
- cmake-utils_src_configure
+ cmake_src_configure
# bug #630232
sed -i "s:\"${T//:\\:}/${EPYTHON}/bin/python\":\"${PYTHON}\":" \
@@ -314,7 +315,7 @@ python_compile() {
}
src_compile() {
- cmake-utils_src_make VERBOSE=1 all
+ cmake_build VERBOSE=1 all
# we have to do this here to prevent from building everything multiple times
python_copy_sources
@@ -335,7 +336,7 @@ python_install() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
python_foreach_impl python_install
find "${ED}" -name '*.la' -type f -delete || die