summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-13 20:23:51 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-13 20:23:51 -0600
commitf741ca90126b001763694738673d8a14a1bde594 (patch)
tree40eaf70cdbcc6db777aa3ea4a95ae4bdfc7af1e1 /sys-cluster
parentdev-libs/zlog: Revbump to 1.2.12-r1, handle libdir properly #628732 (diff)
downloadgentoo-f741ca90126b001763694738673d8a14a1bde594.tar.gz
gentoo-f741ca90126b001763694738673d8a14a1bde594.tar.bz2
gentoo-f741ca90126b001763694738673d8a14a1bde594.zip
sys-cluster/heat: 9.0.3 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/heat/Manifest2
-rw-r--r--sys-cluster/heat/heat-2017.2.9999.ebuild20
-rw-r--r--sys-cluster/heat/heat-9.0.3.ebuild169
3 files changed, 184 insertions, 7 deletions
diff --git a/sys-cluster/heat/Manifest b/sys-cluster/heat/Manifest
index ebe3a36063d4..ed3fd123a989 100644
--- a/sys-cluster/heat/Manifest
+++ b/sys-cluster/heat/Manifest
@@ -1,3 +1,5 @@
DIST heat-9.0.2.tar.gz 2364044 BLAKE2B ca2c6e1f504e7b443906e1c33d2105293313223d9af851a5c46719b5c74d95687d11ea2460f7fc3e818719c9132bb8e0041b4ae123d5a0eb12b5bff22606f474 SHA512 c27dbcd74abed231b5e375461c03e32d5a55c08d04619bf7f315baad14fb20e2041aa92656b7e597bc7c804533c6496f569ce450e81a52cab5735d6d84af2734
+DIST heat-9.0.3.tar.gz 2364843 BLAKE2B 4edbd6716a84e6003cd02511e8c8036c84510bd4d842d9a32caae7c837bee591fb46d3edc8786d8015b8ffd09d4dde7bde4f49a6994766af40284715b2b99713 SHA512 5db5f0189da095951963d2cf30c7c3279e40537041a66b3d13cfebd13ba4256b74db49ba6269e14b2c4e21d10b7b00e77d5b94050e30c436dc271b406e4e9432
DIST heat.conf.sample-2017.2.9999 88901 BLAKE2B 050cfaacb46a8d9b79a17b7406acf6bca9be27a21f8278194021cadc69fb364c630ca0f0e7a320dfe9d46303d779eb8b5c31efaa9c25d3695caf70cab18b1b4d SHA512 f62feaa4a0d27866876aed9f78099501247ae4b7deaefd04d77b1f4b2a1d1c991e6f3e68d9f82e3b6a4358c99fbffd90f14a05ff98105df0ef0db68ef8bc6932
DIST heat.conf.sample-9.0.2 88901 BLAKE2B 050cfaacb46a8d9b79a17b7406acf6bca9be27a21f8278194021cadc69fb364c630ca0f0e7a320dfe9d46303d779eb8b5c31efaa9c25d3695caf70cab18b1b4d SHA512 f62feaa4a0d27866876aed9f78099501247ae4b7deaefd04d77b1f4b2a1d1c991e6f3e68d9f82e3b6a4358c99fbffd90f14a05ff98105df0ef0db68ef8bc6932
+DIST heat.conf.sample-9.0.3 88901 BLAKE2B 050cfaacb46a8d9b79a17b7406acf6bca9be27a21f8278194021cadc69fb364c630ca0f0e7a320dfe9d46303d779eb8b5c31efaa9c25d3695caf70cab18b1b4d SHA512 f62feaa4a0d27866876aed9f78099501247ae4b7deaefd04d77b1f4b2a1d1c991e6f3e68d9f82e3b6a4358c99fbffd90f14a05ff98105df0ef0db68ef8bc6932
diff --git a/sys-cluster/heat/heat-2017.2.9999.ebuild b/sys-cluster/heat/heat-2017.2.9999.ebuild
index 08a656c38a7a..472f8a0a47db 100644
--- a/sys-cluster/heat/heat-2017.2.9999.ebuild
+++ b/sys-cluster/heat/heat-2017.2.9999.ebuild
@@ -4,17 +4,24 @@
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5} )
-inherit distutils-r1 eutils git-r3 linux-info user
+inherit distutils-r1 eutils linux-info user
DESCRIPTION="A CloudFormation-compatible openstack-native cloud orchestration engine."
HOMEPAGE="https://launchpad.net/heat"
-SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/heat/heat.conf.sample.pike -> heat.conf.sample-${PV}"
-EGIT_REPO_URI="https://github.com/openstack/heat.git"
-EGIT_BRANCH="stable/pike"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/heat/heat.conf.sample.pike -> heat.conf.sample-${PV}"
+ EGIT_REPO_URI="https://github.com/openstack/heat.git"
+ EGIT_BRANCH="stable/pike"
+else
+ SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/heat/heat.conf.sample.pike -> heat.conf.sample-${PV}
+ https://tarballs.openstack.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS=""
IUSE="+mysql +memcached postgres sqlite"
REQUIRED_USE="|| ( mysql postgres sqlite )"
@@ -81,8 +88,7 @@ RDEPEND="
>=dev-python/python-monascaclient-1.7.0[${PYTHON_USEDEP}]
>=dev-python/python-neutronclient-6.3.0[${PYTHON_USEDEP}]
>=dev-python/python-novaclient-9.0.0[${PYTHON_USEDEP}]
- >=dev-python/python-openstackclient-3.3.0[${PYTHON_USEDEP}]
- !~dev-python/python-openstackclient-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.11.0[${PYTHON_USEDEP}]
>=dev-python/python-saharaclient-1.1.0[${PYTHON_USEDEP}]
>=dev-python/python-senlinclient-1.1.0[${PYTHON_USEDEP}]
>=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}]
diff --git a/sys-cluster/heat/heat-9.0.3.ebuild b/sys-cluster/heat/heat-9.0.3.ebuild
new file mode 100644
index 000000000000..472f8a0a47db
--- /dev/null
+++ b/sys-cluster/heat/heat-9.0.3.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1 eutils linux-info user
+
+DESCRIPTION="A CloudFormation-compatible openstack-native cloud orchestration engine."
+HOMEPAGE="https://launchpad.net/heat"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/heat/heat.conf.sample.pike -> heat.conf.sample-${PV}"
+ EGIT_REPO_URI="https://github.com/openstack/heat.git"
+ EGIT_BRANCH="stable/pike"
+else
+ SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/heat/heat.conf.sample.pike -> heat.conf.sample-${PV}
+ https://tarballs.openstack.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+mysql +memcached postgres sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ app-admin/sudo"
+
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/croniter-0.3.4[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-1.6.0[${PYTHON_USEDEP}]
+ !~dev-python/cryptography-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/keystonemiddleware-4.12.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ !~dev-python/lxml-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.13[${PYTHON_USEDEP}]
+ !~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.9.17[${PYTHON_USEDEP}]
+ >=dev-python/oslo-cache-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.3.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-db-4.24.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-messaging-5.24.2[${PYTHON_USEDEP}]
+ !~dev-python/oslo-messaging-5.25.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-middleware-3.27.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-policy-1.23.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-reports-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-service-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
+ >=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-versionedobjects-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
+ >=dev-python/aodhclient-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/python-barbicanclient-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.0[${PYTHON_USEDEP}]
+ !~dev-python/python-barbicanclient-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-ceilometerclient-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/python-cinderclient-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-designateclient-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/python-glanceclient-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python-heatclient-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python-magnumclient-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-manilaclient-1.12.0[${PYTHON_USEDEP}]
+ >=dev-python/python-mistralclient-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-monascaclient-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/python-neutronclient-6.3.0[${PYTHON_USEDEP}]
+ >=dev-python/python-novaclient-9.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.11.0[${PYTHON_USEDEP}]
+ >=dev-python/python-saharaclient-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-senlinclient-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-troveclient-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-zaqarclient-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-zunclient-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/tenacity-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/routes-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ sqlite? (
+ >=dev-python/sqlalchemy-1.0.10[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.5[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.6[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.7[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.8[sqlite,${PYTHON_USEDEP}]
+ )
+ mysql? (
+ >=dev-python/pymysql-0.7.6[${PYTHON_USEDEP}]
+ !~dev-python/pymysql-0.7.7[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.5[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.6[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.7[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.8[${PYTHON_USEDEP}]
+ )
+ postgres? (
+ >=dev-python/psycopg-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.5[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.6[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.7[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.8[${PYTHON_USEDEP}]
+ )
+ >=dev-python/sqlalchemy-migrate-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/yaql-1.1.0[${PYTHON_USEDEP}]"
+
+PATCHES=(
+)
+
+pkg_setup() {
+ enewgroup heat
+ enewuser heat -1 -1 /var/lib/heat heat
+}
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ diropts -m0750 -o heat -g heat
+ keepdir /etc/heat
+ dodir /etc/heat/environment.d
+ dodir /etc/heat/templates
+
+ for svc in api api-cfn engine; do
+ newinitd "${FILESDIR}/heat.initd" heat-${svc}
+ done
+
+ insinto /etc/heat
+ insopts -m0640 -o heat -g heat
+ newins "${DISTDIR}/heat.conf.sample-${PV}" "heat.conf.sample"
+ doins "etc/heat/api-paste.ini"
+ doins "etc/heat/policy.json"
+ insinto /etc/heat/templates
+ doins "etc/heat/templates/"*
+ insinto /etc/heat/environment.d
+ doins "etc/heat/environment.d/default.yaml"
+
+ dodir /var/log/heat
+ fowners heat:heat /var/log/heat
+}