summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-26 12:37:11 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-26 12:52:19 +0200
commit14f137cd0a9f2495e0013adbbfe71946fc42550d (patch)
tree4ed30e919b468ce6c58a4d5eaec10e82745c11ff /sys-devel/autoconf-wrapper/autoconf-wrapper-13-r1.ebuild
parentmedia-libs/libwebp: Bump to version 1.0.0. Removed old. (diff)
downloadgentoo-14f137cd0a9f2495e0013adbbfe71946fc42550d.tar.gz
gentoo-14f137cd0a9f2495e0013adbbfe71946fc42550d.tar.bz2
gentoo-14f137cd0a9f2495e0013adbbfe71946fc42550d.zip
sys-devel/autoconf-wrapper: Don't use bashisms.
Closes: https://bugs.gentoo.org/650152 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'sys-devel/autoconf-wrapper/autoconf-wrapper-13-r1.ebuild')
-rw-r--r--sys-devel/autoconf-wrapper/autoconf-wrapper-13-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/autoconf-wrapper/autoconf-wrapper-13-r1.ebuild b/sys-devel/autoconf-wrapper/autoconf-wrapper-13-r1.ebuild
new file mode 100644
index 000000000000..b1847c7e75a5
--- /dev/null
+++ b/sys-devel/autoconf-wrapper/autoconf-wrapper-13-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib
+
+DESCRIPTION="wrapper for autoconf to manage multiple autoconf versions"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_install() {
+ exeinto /usr/$(get_libdir)/misc
+ newexe "${FILESDIR}"/ac-wrapper-${PV}.sh ac-wrapper.sh
+
+ dodir /usr/bin
+ local x=
+ for x in auto{conf,header,m4te,reconf,scan,update} ifnames ; do
+ dosym ../$(get_libdir)/misc/ac-wrapper.sh /usr/bin/${x}
+ done
+}