summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-09-24 15:31:53 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-24 15:33:31 +0200
commit0ae69faf0a570e57ea9a8c54308770e2c0fd3962 (patch)
tree7335bce6a0ff43ebf1b9e6db38300900c1c0364b /sys-devel/automake/automake-1.15.1-r2.ebuild
parentprofiles/use.mask: Unmask postgres-13 POSTGRES_TARGETS (diff)
downloadgentoo-0ae69faf0a570e57ea9a8c54308770e2c0fd3962.tar.gz
gentoo-0ae69faf0a570e57ea9a8c54308770e2c0fd3962.tar.bz2
gentoo-0ae69faf0a570e57ea9a8c54308770e2c0fd3962.zip
sys-devel/automake: Great EAPI-7 bump
- Removed all python2 stuff from ebuilds - Restrict tests for all ebuilds that required python2 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel/automake/automake-1.15.1-r2.ebuild')
-rw-r--r--sys-devel/automake/automake-1.15.1-r2.ebuild38
1 files changed, 19 insertions, 19 deletions
diff --git a/sys-devel/automake/automake-1.15.1-r2.ebuild b/sys-devel/automake/automake-1.15.1-r2.ebuild
index 80447194c28f..8ec205e95c9c 100644
--- a/sys-devel/automake/automake-1.15.1-r2.ebuild
+++ b/sys-devel/automake/automake-1.15.1-r2.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-any-r1 versionator
+EAPI=7
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.savannah.gnu.org/r/${PN}.git"
@@ -17,7 +14,7 @@ else
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
https://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
else
- MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
+ MY_PV="$(ver_cut 1).$(($(ver_cut 2)-1))b"
MY_P="${PN}-${MY_PV}"
# Alpha/beta releases are not distributed on the usual mirrors.
@@ -32,23 +29,19 @@ HOMEPAGE="https://www.gnu.org/software/automake/"
LICENSE="GPL-2"
# Use Gentoo versioning for slotting.
SLOT="${PV:0:4}"
-IUSE="test"
-RESTRICT="!test? ( test )"
+IUSE=""
+RESTRICT="test"
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-10
>=sys-devel/autoconf-2.69:*
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
- sys-apps/help2man
- test? ( ${PYTHON_DEPS} )"
+ sys-apps/help2man"
+BDEPEND="app-arch/gzip"
PATCHES=( "${FILESDIR}"/${PN}-1.15-install-sh-avoid-low-risk-race-in-tmp.patch )
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
src_prepare() {
default
export WANT_AUTOCONF=2.5
@@ -66,7 +59,7 @@ src_prepare() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${ED%/}"/usr/share/info >/dev/null || die
+ pushd "${ED}"/usr/share/info >/dev/null || die
rm -f dir || die
# Rewrite all the references to other pages.
@@ -96,16 +89,23 @@ src_install() {
default
slot_info_pages
- rm "${ED%/}"/usr/share/aclocal/README || die
- rmdir "${ED%/}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
rm \
- "${ED%/}"/usr/bin/{aclocal,automake} \
- "${ED%/}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
local x
for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
+ dosym ../gnuconfig/config.${x} \
+ /usr/share/${PN}-${SLOT}/config.${x}
done
+
+ # Avoid QA message about pre-compressed file in docs
+ local tarfile="${ED}/usr/share/doc/${PF}/amhello-1.0.tar.gz"
+ if [[ -f "${tarfile}" ]] ; then
+ gunzip "${tarfile}" || die
+ fi
}