summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-21 19:25:03 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-21 19:25:23 +0100
commit3ba8fba9d97871f90087048fc5bd2f85a6583f8a (patch)
tree523ff38a92e6d4affb2e29f85548cc33d8931eae /sys-devel/binutils-config
parentdev-ada/aunit: Version bump to 2020 (diff)
downloadgentoo-3ba8fba9d97871f90087048fc5bd2f85a6583f8a.tar.gz
gentoo-3ba8fba9d97871f90087048fc5bd2f85a6583f8a.tar.bz2
gentoo-3ba8fba9d97871f90087048fc5bd2f85a6583f8a.zip
sys-devel/binutils-config: bump up to 5.2.1
First release from packages tarball. Should be identical to 5.2 release otherwise. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/binutils-config')
-rw-r--r--sys-devel/binutils-config/Manifest1
-rw-r--r--sys-devel/binutils-config/binutils-config-5.2.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-devel/binutils-config/Manifest b/sys-devel/binutils-config/Manifest
new file mode 100644
index 000000000000..5def3cddef8d
--- /dev/null
+++ b/sys-devel/binutils-config/Manifest
@@ -0,0 +1 @@
+DIST binutils-config-5.2.1.tar.xz 6200 BLAKE2B e9b5c61e17aeae8b537c485dd555424136d1638182bb92f22f66eac27e18997d45b1a34b1362622bdc21d060ffac8627e9072107561b81c12ee579a55ef40313 SHA512 9ae130da747eaca8ca9717a69be053eba33946fc4101b77fd795d18202e9d6c27f169c29568b5c97b8f581a37f317b72d13b6d61267a61b117e970f3cfbe048b
diff --git a/sys-devel/binutils-config/binutils-config-5.2.1.ebuild b/sys-devel/binutils-config/binutils-config-5.2.1.ebuild
new file mode 100644
index 000000000000..f4763a21b409
--- /dev/null
+++ b/sys-devel/binutils-config/binutils-config-5.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit prefix
+
+DESCRIPTION="Utility to change the binutils version being used"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Toolchain"
+SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+# We also RDEPEND on sys-apps/findutils which is in base @system
+RDEPEND="sys-apps/gentoo-functions"
+
+src_install() {
+ emake DESTDIR="${D}" PV="${PV}" install
+
+ use prefix && eprefixify "${ED}"/usr/bin/${PN}
+ sed -i "s:@PV@:${PVR}:g" "${ED}"/usr/bin/${PN} || die
+}
+
+pkg_preinst() {
+ # Force a refresh when upgrading from an older version that symlinked
+ # in all the libs & includes that binutils-libs handles. #528088
+ if has_version "<${CATEGORY}/${PN}-5" ; then
+ local bc current
+ bc="${ED}/usr/bin/binutils-config"
+ if current=$("${bc}" -c) ; then
+ "${bc}" "${current}"
+ fi
+ fi
+}