summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-14 06:34:31 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-14 08:50:53 +0100
commit4f16e66bcfe4c5a037d6b56373caba7a711c38ce (patch)
tree5927a8df47bf2f76c4ea615896a00ef59cefe1bf /sys-devel/clang-runtime
parentsys-libs/libomp: Bump to 10.0.0rc2 (diff)
downloadgentoo-4f16e66bcfe4c5a037d6b56373caba7a711c38ce.tar.gz
gentoo-4f16e66bcfe4c5a037d6b56373caba7a711c38ce.tar.bz2
gentoo-4f16e66bcfe4c5a037d6b56373caba7a711c38ce.zip
sys-devel/clang-runtime: Bump to 10.0.0rc2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-10.0.0_rc2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-10.0.0_rc2.ebuild b/sys-devel/clang-runtime/clang-runtime-10.0.0_rc2.ebuild
new file mode 100644
index 000000000000..2713d1f397ff
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-10.0.0_rc2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"