summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-06-26 23:23:00 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-27 10:44:39 +0200
commit5f2c980b4185430005c62af3778336302e85e58c (patch)
tree1574162edcb85825ee1fd5ec0d432e2ec99e844f /sys-devel/clang-runtime
parentsys-libs/libomp: Bump to 6.0.1 (diff)
downloadgentoo-5f2c980b4185430005c62af3778336302e85e58c.tar.gz
gentoo-5f2c980b4185430005c62af3778336302e85e58c.tar.bz2
gentoo-5f2c980b4185430005c62af3778336302e85e58c.zip
sys-devel/clang-runtime: Bump to 6.0.1
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-6.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-6.0.1.ebuild b/sys-devel/clang-runtime/clang-runtime-6.0.1.ebuild
new file mode 100644
index 000000000000..9ab9f95ec042
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-6.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="${PV%_*}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ crt? (
+ || (
+ sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+ sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"