summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-09-08 11:21:34 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-08 19:30:43 +0200
commitece68ec8733ae7f2ede22905139958b0b19ac7f1 (patch)
treed56b6d46d051afe3276b74bf4cbd0bc1f2d6a313 /sys-devel/clang-runtime
parentsys-libs/libomp: Bump to 5.0.0 (diff)
downloadgentoo-ece68ec8733ae7f2ede22905139958b0b19ac7f1.tar.gz
gentoo-ece68ec8733ae7f2ede22905139958b0b19ac7f1.tar.bz2
gentoo-ece68ec8733ae7f2ede22905139958b0b19ac7f1.zip
sys-devel/clang-runtime: Bump to 5.0.0
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-5.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-5.0.0.ebuild b/sys-devel/clang-runtime/clang-runtime-5.0.0.ebuild
new file mode 100644
index 000000000000..6b19bc98151c
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-5.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="${PV%_*}"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"