summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-09-10 10:48:14 +0200
committerFabian Groffen <grobian@gentoo.org>2016-09-10 10:48:14 +0200
commitc83c52e6081c171871960fb82e44120f318753b5 (patch)
tree26fcbff585407d1268673098494e371c51672e11 /sys-devel/clang/clang-3.4.2-r100.ebuild
parentsys-devel/llvm: restore llvm-3.4.2 for Prefix bootstraps, bug #588132 (diff)
downloadgentoo-c83c52e6081c171871960fb82e44120f318753b5.tar.gz
gentoo-c83c52e6081c171871960fb82e44120f318753b5.tar.bz2
gentoo-c83c52e6081c171871960fb82e44120f318753b5.zip
sys-devel/clang: restore clang-3.4.2 for Prefix bootstraps, bug #588132
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-devel/clang/clang-3.4.2-r100.ebuild')
-rw-r--r--sys-devel/clang/clang-3.4.2-r100.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-3.4.2-r100.ebuild b/sys-devel/clang/clang-3.4.2-r100.ebuild
new file mode 100644
index 000000000000..a76d5d975d91
--- /dev/null
+++ b/sys-devel/clang/clang-3.4.2-r100.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="UoI-NCSA"
+SLOT="0/3.4"
+KEYWORDS="~ppc-macos ~x86-macos ~x64-macos"
+IUSE=""
+
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),${MULTILIB_USEDEP}]"
+
+# Please keep this package around since it's quite likely that we'll
+# return to separate LLVM & clang ebuilds when the cmake build system
+# is complete.
+
+pkg_postinst() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" ; then
+ #add ccache links as clang might get installed after ccache
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
+
+pkg_postrm() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
+ # --remove-links would remove all links, --install-links updates them
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}