summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-15 12:52:45 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-15 15:30:55 +0100
commit729ef70813e39c0f9b325545fe5a0a274e417c32 (patch)
treea5ae5a40381b17e300a73f0e7020947d0adbc90a /sys-devel/clang/clang-9999.ebuild
parentdev-python/louie: Port to EAPI 6 (diff)
downloadgentoo-729ef70813e39c0f9b325545fe5a0a274e417c32.tar.gz
gentoo-729ef70813e39c0f9b325545fe5a0a274e417c32.tar.bz2
gentoo-729ef70813e39c0f9b325545fe5a0a274e417c32.zip
sys-devel/clang: Remove unnecessary LLVM_LIBDIR_SUFFIX
Remove LLVM_LIBDIR_SUFFIX as CMake path is now obtained from llvm-config, and LLVM_LIBDIR_SUFFIX is subsequently obtained from LLVMConfig.cmake.
Diffstat (limited to 'sys-devel/clang/clang-9999.ebuild')
-rw-r--r--sys-devel/clang/clang-9999.ebuild2
1 files changed, 0 insertions, 2 deletions
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 9e4abc9388ec..3dfce9b7a44a 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -133,9 +133,7 @@ src_prepare() {
multilib_src_configure() {
local llvm_version=$(llvm-config --version) || die
local clang_version=$(get_version_component_range 1-3 "${llvm_version}")
- local libdir=$(get_libdir)
local mycmakeargs=(
- -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
# ensure that the correct llvm-config is used
-DLLVM_CONFIG="${EPREFIX}/usr/bin/${CHOST}-llvm-config"
# relative to bindir