summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-24 17:52:53 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-03 10:27:43 +0200
commit66165c1f42e0fddf82bb7f5bc90797f9874e4ee0 (patch)
treea832b8cac456e37277b2416398f9c30720dddf21 /sys-devel/clang
parentsys-devel/llvm: Drop old revisions (diff)
downloadgentoo-66165c1f42e0fddf82bb7f5bc90797f9874e4ee0.tar.gz
gentoo-66165c1f42e0fddf82bb7f5bc90797f9874e4ee0.tar.bz2
gentoo-66165c1f42e0fddf82bb7f5bc90797f9874e4ee0.zip
sys-devel/clang: Remove 3.9.0 (old intermediate version)
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-3.9.0-r100.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/sys-devel/clang/clang-3.9.0-r100.ebuild b/sys-devel/clang/clang-3.9.0-r100.ebuild
deleted file mode 100644
index 34ac7c96826d..000000000000
--- a/sys-devel/clang/clang-3.9.0-r100.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit multilib-build
-
-DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
-HOMEPAGE="http://clang.llvm.org/"
-SRC_URI=""
-
-# Keep in sync with sys-devel/llvm
-ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Mips MSP430
- NVPTX PowerPC Sparc SystemZ X86 XCore )
-ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
-LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
-
-LICENSE="UoI-NCSA"
-# keep in sync with sys-devel/llvm!
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="debug multitarget python +static-analyzer ${ALL_LLVM_TARGETS[*]}"
-
-RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,python?,static-analyzer?,${LLVM_TARGET_USEDEPS// /,},${MULTILIB_USEDEP}]"
-
-REQUIRED_USE="
- || ( ${ALL_LLVM_TARGETS[*]} )
- multitarget? ( ${ALL_LLVM_TARGETS[*]} )"
-
-# Please keep this package around since it's quite likely that we'll
-# return to separate LLVM & clang ebuilds when the cmake build system
-# is complete.
-
-pkg_postinst() {
- if has_version ">=dev-util/ccache-3.1.9-r2" ; then
- #add ccache links as clang might get installed after ccache
- "${EROOT}"/usr/bin/ccache-config --install-links
- fi
-}
-
-pkg_postrm() {
- if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
- # --remove-links would remove all links, --install-links updates them
- "${EROOT}"/usr/bin/ccache-config --install-links
- fi
-}