summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-10-25 17:40:22 +0200
committerMichał Górny <mgorny@gentoo.org>2016-10-25 18:42:07 +0200
commit724c2d913874778d6527b9200c9be679215fbfcf (patch)
tree7e59e1efe04c374dcb750c0786f1592576abe5f4 /sys-devel/clang
parentapp-admin/vault: skip useless files /usr/lib/go-gentoo (diff)
downloadgentoo-724c2d913874778d6527b9200c9be679215fbfcf.tar.gz
gentoo-724c2d913874778d6527b9200c9be679215fbfcf.tar.bz2
gentoo-724c2d913874778d6527b9200c9be679215fbfcf.zip
sys-devel/clang: Fix enabling EH & RTTI reliably
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 65444a8b1ba9..a4bbcfa8360b 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -145,6 +145,10 @@ multilib_src_configure() {
# TODO: get them properly conditional
#-DLLVM_BUILD_TESTS=$(usex test)
+ # these are not propagated reliably, so redefine them
+ -DLLVM_ENABLE_EH=ON
+ -DLLVM_ENABLE_RTTI=ON
+
-DCMAKE_DISABLE_FIND_PACKAGE_LibXml2=$(usex !xml)
# libgomp support fails to find headers without explicit -I
# furthermore, it provides only syntax checking