summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-06 09:15:11 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-06 14:47:55 +0200
commit76121eeaf8b4414993be55fe37ae9bb196d71719 (patch)
tree0b20008c0497bb4061971a0784da8e16a4b08815 /sys-devel/clang
parentsys-devel/llvm: Fix compressing manpages (diff)
downloadgentoo-76121eeaf8b4414993be55fe37ae9bb196d71719.tar.gz
gentoo-76121eeaf8b4414993be55fe37ae9bb196d71719.tar.bz2
gentoo-76121eeaf8b4414993be55fe37ae9bb196d71719.zip
sys-devel/clang: Fix compressing manpages
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-4.0.0-r1.ebuild (renamed from sys-devel/clang/clang-4.0.0.ebuild)2
-rw-r--r--sys-devel/clang/clang-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-4.0.0.ebuild b/sys-devel/clang/clang-4.0.0-r1.ebuild
index bdfc16ce04a4..cd232123da27 100644
--- a/sys-devel/clang/clang-4.0.0.ebuild
+++ b/sys-devel/clang/clang-4.0.0-r1.ebuild
@@ -291,4 +291,6 @@ multilib_src_install_all() {
if use static-analyzer; then
python_optimize "${ED}"usr/lib/llvm/${SLOT}/share/scan-view
fi
+
+ docompress "/usr/lib/llvm/${SLOT}/share/man"
}
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index f862c7b8a59c..03ed29156ba4 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -288,4 +288,6 @@ multilib_src_install_all() {
if use static-analyzer; then
python_optimize "${ED}"usr/lib/llvm/${SLOT}/share/scan-view
fi
+
+ docompress "/usr/lib/llvm/${SLOT}/share/man"
}