summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-09-02 22:32:48 +0200
committerMichał Górny <mgorny@gentoo.org>2016-09-02 23:40:00 +0200
commitd236c73285432b874fea74b1e4f6afc7b606e751 (patch)
tree8e55d75b789dbde974d821dcb864c72eda700cd8 /sys-devel/clang
parentprofiles/hardened/linux/amd64/package.use.stable.mask: unmask media-video/vlc... (diff)
downloadgentoo-d236c73285432b874fea74b1e4f6afc7b606e751.tar.gz
gentoo-d236c73285432b874fea74b1e4f6afc7b606e751.tar.bz2
gentoo-d236c73285432b874fea74b1e4f6afc7b606e751.zip
sys-devel/clang: Remove unnecessary llvm-lit search patch
Remove the llvm-lit search patch since it is no longer necessary and its correctness is doubtful. Per https://reviews.llvm.org/D23743 the name llvm-lit is not intended for system-wide install of lit. However, this does not matter since the internal copy of lit is used when LLVM source checkout is available, and unittests require this checkout to be available when running tests.
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-9999.ebuild2
-rw-r--r--sys-devel/clang/files/9999/0004-cmake-Adjust-llvm-lit-search-to-match-the-one-in-LLV.patch29
2 files changed, 0 insertions, 31 deletions
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 862afbda6e4c..1c89ad5d9912 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -99,8 +99,6 @@ src_prepare() {
# automatically select active system GCC's libraries, bugs #406163 and #417913
# TODO: cross-linux tests broken by this one
eapply "${FILESDIR}"/9999/0002-driver-Support-obtaining-active-toolchain-from-gcc-c.patch
- # adjust llvm-lit search to match LLVM cmake macros
- eapply "${FILESDIR}"/9999/0004-cmake-Adjust-llvm-lit-search-to-match-the-one-in-LLV.patch
# support overriding clang runtime install directory
eapply "${FILESDIR}"/9999/0005-cmake-Supporting-overriding-runtime-libdir-via-CLANG.patch
# support overriding LLVMgold.so plugin directory
diff --git a/sys-devel/clang/files/9999/0004-cmake-Adjust-llvm-lit-search-to-match-the-one-in-LLV.patch b/sys-devel/clang/files/9999/0004-cmake-Adjust-llvm-lit-search-to-match-the-one-in-LLV.patch
deleted file mode 100644
index bcf409c71b67..000000000000
--- a/sys-devel/clang/files/9999/0004-cmake-Adjust-llvm-lit-search-to-match-the-one-in-LLV.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From d7bc0e05e8064e0c939db6c2fb6d215fd0340708 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sun, 21 Aug 2016 23:30:39 +0200
-Subject: [PATCH 4/7] cmake: Adjust llvm-lit search to match the one in LLVM
-
-Adjust the system lit executable search to look for llvm-lit as that is
-the name used in AddLLVM.cmake installed by LLVM.
-
-Patch: https://reviews.llvm.org/D23745
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index aee0d0a..e95ab52 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -140,7 +140,7 @@ Please install Python or specify the PYTHON_EXECUTABLE CMake variable.")
- endif()
- else()
- # Seek installed Lit.
-- find_program(LLVM_LIT "lit.py" ${LLVM_MAIN_SRC_DIR}/utils/lit
-+ find_program(LLVM_LIT "llvm-lit" ${LLVM_MAIN_SRC_DIR}/utils/lit
- DOC "Path to lit.py")
- endif()
-
---
-2.9.3
-