summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLara Maia <dev@lara.click>2016-02-18 12:51:24 -0200
committerLara Maia <dev@lara.click>2016-02-18 12:53:43 -0200
commit83ff3dd2c6eea0aeb079ccfcd57f0608d9572827 (patch)
tree533b01bdc6928fb0ac436d857025104287f47395 /sys-devel/crossdev/crossdev-20151026-r1.ebuild
parentdev-java/opencsv: Stable for amd64. Retroactively mark stable for the remaini... (diff)
downloadgentoo-83ff3dd2c6eea0aeb079ccfcd57f0608d9572827.tar.gz
gentoo-83ff3dd2c6eea0aeb079ccfcd57f0608d9572827.tar.bz2
gentoo-83ff3dd2c6eea0aeb079ccfcd57f0608d9572827.zip
sys-devel/crossdev: Update crossdev to use new path for functions.sh
https://bugs.gentoo.org/show_bug.cgi?id=538656
Diffstat (limited to 'sys-devel/crossdev/crossdev-20151026-r1.ebuild')
-rw-r--r--sys-devel/crossdev/crossdev-20151026-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-devel/crossdev/crossdev-20151026-r1.ebuild b/sys-devel/crossdev/crossdev-20151026-r1.ebuild
new file mode 100644
index 000000000000..eb84933ea66a
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20151026-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils
+ sys-apps/gentoo-functions"
+
+src_prepare() {
+ epatch "${FILESDIR}"/use-new-path-for-functions.sh.patch
+}
+
+src_install() {
+ default
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}