summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-09-12 22:36:38 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-21 11:46:00 +0100
commit3779cde67f5530c11bd607ac75dedf698340f91c (patch)
tree65e1ad1af025fec88db101ede2692aed6c8354b5 /sys-devel/crossdev/crossdev-99999999.ebuild
parentnet-misc/r8168: Remove old 8.040.00 (diff)
downloadgentoo-3779cde67f5530c11bd607ac75dedf698340f91c.tar.gz
gentoo-3779cde67f5530c11bd607ac75dedf698340f91c.tar.bz2
gentoo-3779cde67f5530c11bd607ac75dedf698340f91c.zip
sys-devel/crossdev: Move to EAPI 6 and git-r3.
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2317
Diffstat (limited to 'sys-devel/crossdev/crossdev-99999999.ebuild')
-rw-r--r--sys-devel/crossdev/crossdev-99999999.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/sys-devel/crossdev/crossdev-99999999.ebuild b/sys-devel/crossdev/crossdev-99999999.ebuild
index d9e38620c110..459e55e4fb0d 100644
--- a/sys-devel/crossdev/crossdev-99999999.ebuild
+++ b/sys-devel/crossdev/crossdev-99999999.ebuild
@@ -2,14 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
-inherit eutils
+EAPI="6"
if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
- inherit git-2
- SRC_URI=""
- #KEYWORDS=""
else
SRC_URI="mirror://gentoo/${P}.tar.xz
https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
@@ -30,13 +27,13 @@ RDEPEND=">=sys-apps/portage-2.1
!sys-devel/crossdev-wrappers"
DEPEND="app-arch/xz-utils"
-src_prepare() {
- epatch "${FILESDIR}"/use-new-path-for-functions.sh.patch
-}
+PATCHES=(
+ "${FILESDIR}"/use-new-path-for-functions.sh.patch
+)
src_install() {
default
if [[ "${PV}" == "99999999" ]] ; then
- sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED%/}"/usr/bin/crossdev || die
fi
}