summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-12-27 18:13:51 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-12-27 18:14:10 +0000
commit15c818497c49912c6fc50ead2cb509dccbb81cdd (patch)
tree19f178b45762f3b6c97dcc22bd57b218ae32947e /sys-devel/crossdev
parentmedia-radio/svxlink: Backport fix for newer gcc from github. (diff)
downloadgentoo-15c818497c49912c6fc50ead2cb509dccbb81cdd.tar.gz
gentoo-15c818497c49912c6fc50ead2cb509dccbb81cdd.tar.bz2
gentoo-15c818497c49912c6fc50ead2cb509dccbb81cdd.zip
sys-devel/crossdev: bump up to 20171227
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20171227.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index 4c5d80fe39c2..bef22882bf31 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1,3 +1,4 @@
DIST crossdev-20151026.tar.xz 22160 BLAKE2B 36cd292ffc9e8051d2684315a1546260ea3de9ff6c1324d8c0463501c1ab2671a998f176220220f8050d3d816bff48d1e263b35fcc50139e6149965d4d163b30 SHA512 f60efd4ad867efd0eb33de5fe327ccbfe73b574c97507bc0edd7ef141ad74c035ae2a0d446180e6a9eb5f43197f44933a452245feec849bacfb03fc07067edd0
DIST crossdev-20160602.tar.xz 22292 BLAKE2B f3ade0af8ce39b6c9a5aed30845e5633b68da0796cd43c9ae05450f8a982027e428fbcca110b485a41c335963ff932c1b5cfcca3aba6143f648bc8f4ed2e27b7 SHA512 580cc51e599086a14c51153e656d30b5c2f0e08c7601384d3e082716edeaa532e832b515df2517618cc51be187fcf8738db10e412a5635a16d0bb58b1631a53e
DIST crossdev-20171119.tar.xz 22596 BLAKE2B 4e606f63aad234684b6400203fc22a9ff7dbd9f14dca5e2f2055f08207e412a3a3352921109100b32b4f6fb51cc0836ada4e8db8011d781e9e7c990d6c92d3d1 SHA512 3b8d7b89adf06d5ffef169ed1015532220c997731e083fd73c27d80ea09a6a7efd456734104aa58ef386426f9a04fed3147f37aefe4106c378a0b865bfffb2f0
+DIST crossdev-20171227.tar.xz 22780 BLAKE2B 983dd5da66c1e467b622867c9d474c7e1b7befd4fb91e1e008f7d7d8416bb077bcd06274fe8145ec9338f652e780d2ddd3a501f79b46af280cb5dbb4c8324965 SHA512 bc91e95aa9a927416f2b97b989657de5a740707bb4f4cbfc3d9e0626c3977b3091040104a52205762ef9cc0d3cd7933fb527efa20086dedfd9b390dc2be167a0
diff --git a/sys-devel/crossdev/crossdev-20171227.ebuild b/sys-devel/crossdev/crossdev-20171227.ebuild
new file mode 100644
index 000000000000..73d9c4690063
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20171227.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED%/}"/usr/bin/crossdev || die
+ fi
+}