summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-04-18 08:10:03 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-04-18 08:10:03 -0400
commitd12755ac88833aa54c0b1a63ba3ee9c54e5b62f2 (patch)
tree7ad443ecb839048dbe1cde2a3f877e3e75796a39 /sys-devel/ct-ng/ct-ng-1.24.0.ebuild
parentdev-util/valgrind: version bump to 3.15.0 (diff)
downloadgentoo-d12755ac88833aa54c0b1a63ba3ee9c54e5b62f2.tar.gz
gentoo-d12755ac88833aa54c0b1a63ba3ee9c54e5b62f2.tar.bz2
gentoo-d12755ac88833aa54c0b1a63ba3ee9c54e5b62f2.zip
sys-devel/ct-ng: version bump to 1.24.0
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'sys-devel/ct-ng/ct-ng-1.24.0.ebuild')
-rw-r--r--sys-devel/ct-ng/ct-ng-1.24.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/ct-ng/ct-ng-1.24.0.ebuild b/sys-devel/ct-ng/ct-ng-1.24.0.ebuild
new file mode 100644
index 000000000000..ebcbb34f2c48
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.24.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="https://crosstool-ng.github.io/"
+MY_P=${P/ct/crosstool}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+S="${WORKDIR}/crosstool-ng-${PV}"
+
+src_install() {
+ emake DESTDIR="${D%/}" install
+ use doc && mv "${D}"/usr/share/doc/crosstool-ng/crosstool-ng-${PVR} \
+ "${D}"/usr/share/doc/
+ rm -rf "${D}"/usr/share/doc/crosstool-ng
+}