summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Gupta <manojgupta@google.com>2020-06-10 14:40:11 -0700
committerMike Gilbert <floppym@gentoo.org>2020-06-13 10:57:29 -0400
commit3370923f46b01137d4e48d89c58a3b13eb2c10a6 (patch)
tree52258971cc7da4b3df940fabaff0d8b311bef1c8 /sys-devel/flex
parentdev-libs/nettle: Respect portage host cc variable (diff)
downloadgentoo-3370923f46b01137d4e48d89c58a3b13eb2c10a6.tar.gz
gentoo-3370923f46b01137d4e48d89c58a3b13eb2c10a6.tar.bz2
gentoo-3370923f46b01137d4e48d89c58a3b13eb2c10a6.zip
sys-devel/flex: Respect portage host cc variable
Pass CC_FOR_BUILD to econf. Otherwise it invokes gcc instead of portage specified HOST/BUILD CC. Signed-off-by: Manoj Gupta <manojgupta@google.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/16177
Diffstat (limited to 'sys-devel/flex')
-rw-r--r--sys-devel/flex/flex-2.6.4-r1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-devel/flex/flex-2.6.4-r1.ebuild b/sys-devel/flex/flex-2.6.4-r1.ebuild
index e040402480de..6d18e2634000 100644
--- a/sys-devel/flex/flex-2.6.4-r1.ebuild
+++ b/sys-devel/flex/flex-2.6.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
-inherit eutils flag-o-matic libtool ltprune multilib-minimal
+inherit eutils flag-o-matic libtool ltprune multilib-minimal toolchain-funcs
DESCRIPTION="The Fast Lexical Analyzer"
HOMEPAGE="https://flex.sourceforge.net/ https://github.com/westes/flex"
@@ -50,6 +50,7 @@ multilib_src_configure() {
# Do not install shared libs #503522
ECONF_SOURCE=${S} \
econf \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)" \
--disable-shared \
$(use_enable nls)
}