summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-09-05 19:15:49 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-09-05 19:16:59 +0100
commitd99d0caf31f86a1ba52c60b8576c835a7a047c2e (patch)
treeb8c710e25c1ead59ca472d7100f38c4e71b366ba /sys-devel/gcc-config/gcc-config-2.3.2.ebuild
parentdev-perl/File-Slurp: Bump to version 9999.320.0 (diff)
downloadgentoo-d99d0caf31f86a1ba52c60b8576c835a7a047c2e.tar.gz
gentoo-d99d0caf31f86a1ba52c60b8576c835a7a047c2e.tar.bz2
gentoo-d99d0caf31f86a1ba52c60b8576c835a7a047c2e.zip
sys-devel/gcc-config: bump up to 2.3.2
Two new changes: - make USE_CC_WRAPPERS=yes to install cc/f77 links - maintain ABI ordering for LDPATH Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gcc-config/gcc-config-2.3.2.ebuild')
-rw-r--r--sys-devel/gcc-config/gcc-config-2.3.2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-devel/gcc-config/gcc-config-2.3.2.ebuild b/sys-devel/gcc-config/gcc-config-2.3.2.ebuild
new file mode 100644
index 000000000000..f18c030a06c7
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-2.3.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gcc-config.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Utility to manage compilers"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gcc-config.git/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+native-symlinks"
+
+RDEPEND=">=sys-apps/gentoo-functions-0.10"
+
+_emake() {
+ emake \
+ PV="${PV}" \
+ SUBLIBDIR="$(get_libdir)" \
+ USE_NATIVE_LINKS="$(usex native-symlinks)" \
+ TOOLCHAIN_PREFIX="${CHOST}-" \
+ "$@"
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ # Scrub eselect-compiler remains.
+ # To be removed in 2021.
+ rm -f "${ROOT}"/etc/env.d/05compiler
+
+ # We not longer use the /usr/include/g++-v3 hacks, as
+ # it is not needed ...
+ # To be removed in 2021.
+ rm -f "${ROOT}"/usr/include/g++{,-v3}
+
+ # Do we have a valid multi ver setup ?
+ local x
+ for x in $(gcc-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
+ gcc-config ${x}
+ done
+
+ # USE flag change can add or delete files in /usr/bin worth recaching
+ if [[ ! ${ROOT} && -f ${EPREFIX}/usr/share/eselect/modules/compiler-shadow.eselect ]] ; then
+ eselect compiler-shadow update all
+ fi
+}