summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-01 14:52:51 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-02 00:40:25 +0100
commitaf80621b07f943bce5280a00468f2688c2df23b1 (patch)
tree6d0685f16e3849718feb743d8e17f02842339566 /sys-devel/gcc-config
parentsci-libs/pymmlib: [QA] Fix DESCRIPTION.toolong (diff)
downloadgentoo-af80621b07f943bce5280a00468f2688c2df23b1.tar.gz
gentoo-af80621b07f943bce5280a00468f2688c2df23b1.tar.bz2
gentoo-af80621b07f943bce5280a00468f2688c2df23b1.zip
sys-devel/gcc-config: Fix storing libdir & PV in installed executable
Fix the ebuild to pass libdir & PV during src_compile() rather than delaying it until src_install(). This is necessary since the gcc-config executable is created during the compile phase, and there is no reason why make would recreate it during install. As a result, gcc-config was installed with vanilla 'lib' libdir and 'git' version.
Diffstat (limited to 'sys-devel/gcc-config')
-rw-r--r--sys-devel/gcc-config/gcc-config-1.9.0-r1.ebuild (renamed from sys-devel/gcc-config/gcc-config-1.9.0.ebuild)4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-devel/gcc-config/gcc-config-1.9.0.ebuild b/sys-devel/gcc-config/gcc-config-1.9.0-r1.ebuild
index f6b9422871d9..b27cc3b5c419 100644
--- a/sys-devel/gcc-config/gcc-config-1.9.0.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.9.0-r1.ebuild
@@ -18,7 +18,9 @@ IUSE=""
RDEPEND=">=sys-apps/gentoo-functions-0.10"
src_compile() {
- emake CC="$(tc-getCC)"
+ emake CC="$(tc-getCC)" \
+ PV="${PV}" \
+ SUBLIBDIR="$(get_libdir)"
}
src_install() {