summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-06-15 20:09:00 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-06-15 20:15:11 +0100
commit9f7994e39f52516008523fd52f2bccc3991faec5 (patch)
tree5cce730bc37ee631a0b530a29069fbad766e5d14 /sys-devel/gcc/gcc-3.4.6-r4.ebuild
parentgames-board/pychess: bump to version 0.99.4 (diff)
downloadgentoo-9f7994e39f52516008523fd52f2bccc3991faec5.tar.gz
gentoo-9f7994e39f52516008523fd52f2bccc3991faec5.tar.bz2
gentoo-9f7994e39f52516008523fd52f2bccc3991faec5.zip
sys-devel/gcc: bump patchset to 2 for 3.4.6
Single new patch: 93_all_gperf-inline.patch: fix gcj compilation on modern gcc. Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gcc/gcc-3.4.6-r4.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.4.6-r4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-3.4.6-r4.ebuild b/sys-devel/gcc/gcc-3.4.6-r4.ebuild
new file mode 100644
index 000000000000..97c3f7c26634
--- /dev/null
+++ b/sys-devel/gcc/gcc-3.4.6-r4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="2"
+UCLIBC_VER="1.1"
+UCLIBC_GCC_VER="3.4.5"
+HTB_VER="1.00.1"
+HTB_GCC_VER="3.4.4"
+D_VER="0.24"
+
+inherit eutils toolchain
+
+KEYWORDS="-* ~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+# we need a proper glibc version for the Scrt1.o provided to the pie-ssp specs
+# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
+# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
+# well tested in gentoo on any arch other than amd64!!
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/binutils-2.14.90.0.8-r1
+ amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
+
+src_prepare() {
+ toolchain_src_prepare
+
+ # Anything useful and objc will require libffi. Seriously. Lets just force
+ # libffi to install with USE="objc", even though it normally only installs
+ # if you attempt to build gcj.
+ if use objc && ! use gcj ; then
+ epatch "${FILESDIR}"/3.4.3/libffi-without-libgcj.patch
+ #epatch "${FILESDIR}"/3.4.3/libffi-nogcj-lib-path-fix.patch
+ fi
+
+ # Fix cross-compiling
+ epatch "${FILESDIR}"/3.4.4/gcc-3.4.4-cross-compile.patch
+
+ # Arch stuff
+ case $(tc-arch) in
+ amd64)
+ if is_multilib ; then
+ sed -i -e '/GLIBCXX_IS_NATIVE=/s:false:true:' libstdc++-v3/configure || die
+ fi
+ ;;
+ esac
+}