summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-21 08:21:05 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-21 08:21:15 +0100
commitc4b816a18ebce5dae2343694da3d24ca1a7f3cf3 (patch)
tree1ba6ec78dc4fa02c71b79633838c28328aee7e8f /sys-devel/gdb
parentsci-calculators/bc-gh: bump to 3.1.5 (diff)
downloadgentoo-c4b816a18ebce5dae2343694da3d24ca1a7f3cf3.tar.gz
gentoo-c4b816a18ebce5dae2343694da3d24ca1a7f3cf3.tar.bz2
gentoo-c4b816a18ebce5dae2343694da3d24ca1a7f3cf3.zip
sys-devel/gdb: backport -fno-common build for sim/ppc
Reported-by: Daniel Gurney Closes: https://bugs.gentoo.org/738272 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/files/gdb-9.2-sim-ppc-fno-common.patch97
-rw-r--r--sys-devel/gdb/gdb-9.2.ebuild1
2 files changed, 98 insertions, 0 deletions
diff --git a/sys-devel/gdb/files/gdb-9.2-sim-ppc-fno-common.patch b/sys-devel/gdb/files/gdb-9.2-sim-ppc-fno-common.patch
new file mode 100644
index 000000000000..76b29649ad2e
--- /dev/null
+++ b/sys-devel/gdb/files/gdb-9.2-sim-ppc-fno-common.patch
@@ -0,0 +1,97 @@
+https://bugs.gentoo.org/738272
+https://sourceware.org/git/?p=binutils-gdb.git;a=commitdiff;h=ad8464f799a4c96c7ab8bdfec3f95846cf54f9b0
+
+From ad8464f799a4c96c7ab8bdfec3f95846cf54f9b0 Mon Sep 17 00:00:00 2001
+From: Sebastian Huber <sebastian.huber@embedded-brains.de>
+Date: Wed, 1 Jul 2020 19:29:55 +0200
+Subject: [PATCH] sim/ppc: Fix linker error with -fno-common
+
+GCC 10 enables -fno-common by default. This resulted in a multiple
+definition linker error since global variables were declared and defined
+in a header file:
+
+ ld: ld-insn.o:sim/ppc/ld-insn.h:221: multiple definition of
+ `max_model_fields_len'; igen.o:sim/ppc/ld-insn.h:221: first defined here
+
+sim/ppc
+
+ * ld-insn.h (last_model, last_model_data, last_model_function,
+ last_model_internal, last_model_macro, last_model_static):
+ Delete.
+ (max_model_fields_len, model_data, model_functions,
+ model_internal, model_macros, model_static, models): Declare, but do not
+ define.
+ * ld-insn.c (last_model, last_model_data, last_model_function,
+ last_model_internal, last_model_macro, last_model_static,
+ max_model_fields_len, model_data, model_functions,
+ model_internal, model_macros, model_static, models): Define.
+---
+ sim/ppc/ld-insn.c | 18 ++++++++++++++++++
+ sim/ppc/ld-insn.h | 24 +++++++-----------------
+ 3 files changed, 38 insertions(+), 17 deletions(-)
+
+--- a/sim/ppc/ld-insn.c
++++ b/sim/ppc/ld-insn.c
+@@ -28,6 +28,24 @@
+
+ #include "igen.h"
+
++static model *last_model;
++
++static insn *last_model_macro;
++static insn *last_model_function;
++static insn *last_model_internal;
++static insn *last_model_static;
++static insn *last_model_data;
++
++model *models;
++
++insn *model_macros;
++insn *model_functions;
++insn *model_internal;
++insn *model_static;
++insn *model_data;
++
++int max_model_fields_len;
++
+ static void
+ update_depth(insn_table *entry,
+ lf *file,
+--- a/sim/ppc/ld-insn.h
++++ b/sim/ppc/ld-insn.h
+@@ -200,25 +200,15 @@ extern insn_table *load_insn_table
+ table_include *includes,
+ cache_table **cache_rules);
+
+-model *models;
+-model *last_model;
++extern model *models;
+
+-insn *model_macros;
+-insn *last_model_macro;
++extern insn *model_macros;
++extern insn *model_functions;
++extern insn *model_internal;
++extern insn *model_static;
++extern insn *model_data;
+
+-insn *model_functions;
+-insn *last_model_function;
+-
+-insn *model_internal;
+-insn *last_model_internal;
+-
+-insn *model_static;
+-insn *last_model_static;
+-
+-insn *model_data;
+-insn *last_model_data;
+-
+-int max_model_fields_len;
++extern int max_model_fields_len;
+
+ extern void insn_table_insert_insn
+ (insn_table *table,
+--
+2.28.0
+
diff --git a/sys-devel/gdb/gdb-9.2.ebuild b/sys-devel/gdb/gdb-9.2.ebuild
index a65d6cdd173b..cc5393a18132 100644
--- a/sys-devel/gdb/gdb-9.2.ebuild
+++ b/sys-devel/gdb/gdb-9.2.ebuild
@@ -91,6 +91,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-8.3.1-verbose-build.patch
"${FILESDIR}"/${PN}-9.1-ia64.patch
+ "${FILESDIR}"/${P}-sim-ppc-fno-common.patch
)
GDB_BUILD_DIR="${WORKDIR}"/${P}-build