summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-05-10 20:40:17 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-05-10 20:40:52 +0200
commitf570cd6e3ccfa1b9afae0c875a367a55b75f8f1d (patch)
treef1bd00f7acfeccb3099c1373d3eb6cafeabf04f6 /sys-devel/gettext
parentdev-python/python-heatclient: cleanup of old (diff)
downloadgentoo-f570cd6e3ccfa1b9afae0c875a367a55b75f8f1d.tar.gz
gentoo-f570cd6e3ccfa1b9afae0c875a367a55b75f8f1d.tar.bz2
gentoo-f570cd6e3ccfa1b9afae0c875a367a55b75f8f1d.zip
sys-devel/gettext: Fixed parallel install issue
Thanks-to: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Closes: https://bugs.gentoo.org/685530 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel/gettext')
-rw-r--r--sys-devel/gettext/files/gettext-0.20-avoid_eautomake.patch22
-rw-r--r--sys-devel/gettext/files/gettext-0.20-parallel_install.patch37
-rw-r--r--sys-devel/gettext/gettext-0.20.ebuild2
3 files changed, 61 insertions, 0 deletions
diff --git a/sys-devel/gettext/files/gettext-0.20-avoid_eautomake.patch b/sys-devel/gettext/files/gettext-0.20-avoid_eautomake.patch
new file mode 100644
index 000000000000..16592c8018e0
--- /dev/null
+++ b/sys-devel/gettext/files/gettext-0.20-avoid_eautomake.patch
@@ -0,0 +1,22 @@
+--- gettext-0.20/gettext-tools/src/Makefile.in
++++ gettext-0.20/gettext-tools/src/Makefile.in
+@@ -3952,9 +3952,16 @@
+
+ # How to get the include files of libtextstyle.
+ textstyle.h textstyle/stdbool.h textstyle/version.h textstyle/woe32dll.h:
+- here=`pwd`; \
+- cd ../../libtextstyle/lib && \
+- $(MAKE) install-nobase_includeHEADERS install-nobase_nodist_includeHEADERS includedir="$$here"
++ cd "$(abs_top_builddir)/../libtextstyle/lib" && $(MAKE) $@
++ if test -f "$(abs_top_builddir)/../libtextstyle/lib/$@"; then \
++ file="$(abs_top_builddir)/../libtextstyle/lib/$@"; \
++ else \
++ file="$(abs_top_srcdir)/../libtextstyle/lib/$@"; \
++ fi; \
++ target_dir="$(abs_builddir)/$@"; \
++ target_dir="$${target_dir%/*}"; \
++ $(MKDIR_P) "$${target_dir}"; \
++ $(INSTALL_HEADER) "$$file" $@
+
+ # No need to install libgettextsrc.a, except on AIX.
+ install-exec-hook: install-exec-clean
diff --git a/sys-devel/gettext/files/gettext-0.20-parallel_install.patch b/sys-devel/gettext/files/gettext-0.20-parallel_install.patch
new file mode 100644
index 000000000000..e47beaf94433
--- /dev/null
+++ b/sys-devel/gettext/files/gettext-0.20-parallel_install.patch
@@ -0,0 +1,37 @@
+From 829660df1583c6c3ee1d90291dd910f08e3b777e Mon Sep 17 00:00:00 2001
+From: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
+Date: Fri, 10 May 2019 20:08:25 +0200
+Subject: [PATCH] Fix parallel install issue
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ gettext-tools/src/Makefile.am | 13 ++++++++++---
+ 1 file changed, 10 insertions(+), 3 deletions(-)
+
+diff --git a/gettext-tools/src/Makefile.am b/gettext-tools/src/Makefile.am
+index 09a3c153d..1ee49cdca 100644
+--- a/gettext-tools/src/Makefile.am
++++ b/gettext-tools/src/Makefile.am
+@@ -252,9 +252,16 @@ cldr_plurals_LDADD = libgettextsrc.la $(LDADD)
+
+ # How to get the include files of libtextstyle.
+ textstyle.h textstyle/stdbool.h textstyle/version.h textstyle/woe32dll.h:
+- here=`pwd`; \
+- cd ../../libtextstyle/lib && \
+- $(MAKE) install-nobase_includeHEADERS install-nobase_nodist_includeHEADERS includedir="$$here"
++ cd "$(abs_top_builddir)/../libtextstyle/lib" && $(MAKE) $@
++ if test -f "$(abs_top_builddir)/../libtextstyle/lib/$@"; then \
++ file="$(abs_top_builddir)/../libtextstyle/lib/$@"; \
++ else \
++ file="$(abs_top_srcdir)/../libtextstyle/lib/$@"; \
++ fi; \
++ target_dir="$(abs_builddir)/$@"; \
++ target_dir="$${target_dir%/*}"; \
++ $(MKDIR_P) "$${target_dir}"; \
++ $(INSTALL_HEADER) "$$file" $@
+ BUILT_SOURCES += textstyle.h textstyle/stdbool.h textstyle/version.h textstyle/woe32dll.h
+ MOSTLYCLEANFILES += textstyle.h textstyle/stdbool.h textstyle/version.h textstyle/woe32dll.h
+
+--
+2.21.0
+
diff --git a/sys-devel/gettext/gettext-0.20.ebuild b/sys-devel/gettext/gettext-0.20.ebuild
index e4877a91a2ab..8f4c83d53216 100644
--- a/sys-devel/gettext/gettext-0.20.ebuild
+++ b/sys-devel/gettext/gettext-0.20.ebuild
@@ -51,6 +51,8 @@ MULTILIB_WRAPPED_HEADERS=(
PATCHES=(
"${FILESDIR}"/${PN}-0.19.7-disable-libintl.patch #564168
+ "${FILESDIR}"/${PN}-0.20-parallel_install.patch #685530
+ "${FILESDIR}"/${PN}-0.20-avoid_eautomake.patch
)
pkg_setup() {