summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-07-26 22:21:36 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-07-26 22:23:24 +0100
commitcf042083224309abfdde3f806cc64439412c1bbd (patch)
tree94867e3b8b470bca1264d241935d6e7614c0a20a /sys-devel/kgcc64/kgcc64-8.2.0.ebuild
parentsys-devel/gcc: bump up to 8.2.0 (unkeyworded) (diff)
downloadgentoo-cf042083224309abfdde3f806cc64439412c1bbd.tar.gz
gentoo-cf042083224309abfdde3f806cc64439412c1bbd.tar.bz2
gentoo-cf042083224309abfdde3f806cc64439412c1bbd.zip
sys-devel/kgcc64: bump up to 8.2.0 (unkeyworded)
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-8.2.0.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-8.2.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-devel/kgcc64/kgcc64-8.2.0.ebuild b/sys-devel/kgcc64/kgcc64-8.2.0.ebuild
new file mode 100644
index 000000000000..e050de1d5712
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-8.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_GCC_VER="8.1.0"
+PATCH_VER="1.3"
+inherit eutils toolchain
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on hppa and mips; all other archs, refer to bug #228115
+#KEYWORDS="~hppa ~mips"
+
+RDEPEND=">=dev-libs/gmp-4.3.2
+ >=dev-libs/mpfr-2.4.2
+ >=dev-libs/mpc-0.8.1
+ >=sys-devel/gcc-config-1.4"
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="${RDEPEND}
+ hppa? ( sys-devel/binutils-hppa64 )
+ !sys-devel/gcc-hppa64
+ !sys-devel/gcc-mips64
+ !sys-devel/gcc-powerpc64
+ !sys-devel/gcc-sparc64
+ >=sys-apps/texinfo-4.8
+ >=sys-devel/bison-1.875"
+
+src_prepare() {
+ # upstreamed patches since 8.1.0
+ EPATCH_EXCLUDE+=" 93_all_arm-arch.patch 96_all_lto-O2-PR85655.patch"
+
+ toolchain_src_prepare
+}
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}