summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-07-02 20:09:35 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-02 20:22:09 +0200
commitf8527e2b19b62a25d2fc0c4f68e38db1010b7f5e (patch)
treed0fbdca0c77584c39f48b0d40ad8aa465cbd1569 /sys-devel/llvm-common/llvm-common-4.0.0.ebuild
parentapp-shells/bash-completion: Bump to 2.7 (diff)
downloadgentoo-f8527e2b19b62a25d2fc0c4f68e38db1010b7f5e.tar.gz
gentoo-f8527e2b19b62a25d2fc0c4f68e38db1010b7f5e.tar.bz2
gentoo-f8527e2b19b62a25d2fc0c4f68e38db1010b7f5e.zip
app-vim/llvm-vim -> sys-devel/llvm-common
Rename llvm-vim package to llvm-common. It is going to be reused to include all the common files that are shared between multiple LLVM slots. This should also cut the pointless noise of our valuable users complaining that LLVM unconditionally depends on app-vim/* package.
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-4.0.0.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-4.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-4.0.0.ebuild b/sys-devel/llvm-common/llvm-common-4.0.0.ebuild
new file mode 100644
index 000000000000..d307094d751b
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-4.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="http://llvm.org/"
+SRC_URI="http://releases.llvm.org/${PV/_//}/llvm-${PV/_/}.src.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+S=${WORKDIR}/llvm-${PV/_/}.src
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r utils/vim/*/
+ # some users may find it useful
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
+}