summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-20 15:14:41 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-20 16:01:38 +0100
commitd8b5580f357393bbba80ed1e20f085300d4a1809 (patch)
treee3d1e1673d822075c8e6c876b28b56d11da5a718 /sys-devel/llvm-common/llvm-common-8.0.0.ebuild
parentpackage.mask: Remove LLVM 8.0.0 RC mask (diff)
downloadgentoo-d8b5580f357393bbba80ed1e20f085300d4a1809.tar.gz
gentoo-d8b5580f357393bbba80ed1e20f085300d4a1809.tar.bz2
gentoo-d8b5580f357393bbba80ed1e20f085300d4a1809.zip
sys-devel/llvm-common: Bump to 8.0.0 final
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-8.0.0.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-8.0.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-8.0.0.ebuild b/sys-devel/llvm-common/llvm-common-8.0.0.ebuild
new file mode 100644
index 000000000000..5d3f8596005f
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-8.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=llvm-${PV/_/}.src
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://releases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ einfo "Unpacking parts of ${MY_P}.tar.xz ..."
+ tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/vim" || die
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r utils/vim/*/
+ # some users may find it useful
+ newdoc utils/vim/README README.vim
+ dodoc utils/vim/vimrc
+}