summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-08-25 04:12:17 +0200
committerMichał Górny <mgorny@gentoo.org>2016-08-25 04:12:44 +0200
commit0acb9e257add056f0666ca187cb7d2dd36835558 (patch)
tree4c2d598b81e83f513c1519b08049c297074d0822 /sys-devel/llvm/files
parentsys-fs/s3ql: version bump to 2.20 (diff)
downloadgentoo-0acb9e257add056f0666ca187cb7d2dd36835558.tar.gz
gentoo-0acb9e257add056f0666ca187cb7d2dd36835558.tar.bz2
gentoo-0acb9e257add056f0666ca187cb7d2dd36835558.zip
sys-devel/llvm: Restore gtest patch for <9999, #592046
Diffstat (limited to 'sys-devel/llvm/files')
-rw-r--r--sys-devel/llvm/files/3.8.1/0005-cmake-Do-not-install-libgtest.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-devel/llvm/files/3.8.1/0005-cmake-Do-not-install-libgtest.patch b/sys-devel/llvm/files/3.8.1/0005-cmake-Do-not-install-libgtest.patch
new file mode 100644
index 000000000000..a24977c03140
--- /dev/null
+++ b/sys-devel/llvm/files/3.8.1/0005-cmake-Do-not-install-libgtest.patch
@@ -0,0 +1,30 @@
+From 1303993b5b9a4195ebe4930a8cd345c875e7f25c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Tue, 9 Jun 2015 11:58:52 +0200
+Subject: [PATCH 05/10] cmake: Do not install libgtest
+
+libgtest is an internal test dependency, and should not be installed to
+the live system as a part of LLVM.
+
+Bug: http://llvm.org/bugs/show_bug.cgi?id=18341
+---
+ utils/unittest/CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/utils/unittest/CMakeLists.txt b/utils/unittest/CMakeLists.txt
+index c9a2cdd..bb4f667 100644
+--- a/utils/unittest/CMakeLists.txt
++++ b/utils/unittest/CMakeLists.txt
+@@ -37,6 +37,9 @@ if (PTHREAD_LIBRARY_PATH)
+ list(APPEND LIBS pthread)
+ endif()
+
++# Delay building until the tests pull it in, and avoid installing it
++set(EXCLUDE_FROM_ALL ON)
++
+ add_llvm_library(gtest
+ googletest/src/gtest-all.cc
+
+--
+2.9.3
+