summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-20 12:43:38 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-20 18:32:24 +0200
commit2d8988b97080280eadafb9f695b8fb572ba0587c (patch)
treecc9b5bdadf7d14ff3bb6c2dd6416b149eb324a84 /sys-devel/llvm/llvm-11.0.0.9999.ebuild
parentsys-devel/llvm: Apply patches in WORKDIR in 10.0.1+ (diff)
downloadgentoo-2d8988b97080280eadafb9f695b8fb572ba0587c.tar.gz
gentoo-2d8988b97080280eadafb9f695b8fb572ba0587c.tar.bz2
gentoo-2d8988b97080280eadafb9f695b8fb572ba0587c.zip
sys-devel/llvm: Port to cmake.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm/llvm-11.0.0.9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-11.0.0.9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sys-devel/llvm/llvm-11.0.0.9999.ebuild b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
index b9699a63af7f..0b7c603728a4 100644
--- a/sys-devel/llvm/llvm-11.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
@@ -4,8 +4,8 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils llvm.org multilib-minimal multiprocessing \
- pax-utils python-any-r1 toolchain-funcs
+inherit cmake llvm.org multilib-minimal multiprocessing pax-utils \
+ python-any-r1 toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -195,7 +195,7 @@ src_prepare() {
# cmake eclasses suck by forcing ${S} here
CMAKE_USE_DIR=${S} \
S=${WORKDIR} \
- cmake-utils_src_prepare
+ cmake_src_prepare
}
# Is LLVM being linked against libc++?
@@ -436,13 +436,13 @@ multilib_src_configure() {
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
- cmake-utils_src_configure
+ cmake_src_configure
multilib_is_native_abi && check_distribution_components
}
multilib_src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
pax-mark m "${BUILD_DIR}"/bin/llvm-rtdyld
pax-mark m "${BUILD_DIR}"/bin/lli
@@ -458,7 +458,7 @@ multilib_src_compile() {
multilib_src_test() {
# respect TMPDIR!
local -x LIT_PRESERVES_TMP=1
- cmake-utils_src_make check
+ cmake_build check
}
src_install() {
@@ -478,7 +478,7 @@ src_install() {
}
multilib_src_install() {
- DESTDIR=${D} cmake-utils_src_make install-distribution
+ DESTDIR=${D} cmake_build install-distribution
# move headers to /usr/include for wrapping
rm -rf "${ED}"/usr/include || die