summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-29 20:22:43 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-05-30 13:00:47 +0200
commit5ce42624d550356443f67ec524b739a3f3f1acdb (patch)
treebbbc68d7b8c4766568a989ccd4715ea2b49765e9 /sys-devel/m4
parentapp-office/libreoffice-bin: Fix python version (diff)
downloadgentoo-5ce42624d550356443f67ec524b739a3f3f1acdb.tar.gz
gentoo-5ce42624d550356443f67ec524b739a3f3f1acdb.tar.bz2
gentoo-5ce42624d550356443f67ec524b739a3f3f1acdb.zip
sys-devel/m4: add 1.4.19, drop 1.4.19_beta2
* Add 1.4.19 ** Add USE=nls for new gettext/libintl support ** Add packaging information via configure * Drop 1.4.19_beta2 Signed-off-by: Sam James <sam@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/21044 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel/m4')
-rw-r--r--sys-devel/m4/Manifest2
-rw-r--r--sys-devel/m4/m4-1.4.19.ebuild (renamed from sys-devel/m4/m4-1.4.19_beta2.ebuild)28
2 files changed, 23 insertions, 7 deletions
diff --git a/sys-devel/m4/Manifest b/sys-devel/m4/Manifest
index eba754a6ffdc..c24847bf0235 100644
--- a/sys-devel/m4/Manifest
+++ b/sys-devel/m4/Manifest
@@ -1,2 +1,2 @@
DIST m4-1.4.18.tar.xz 1207688 BLAKE2B debfaa4d25af6f583e2cd703e77b73775790f48f34e878eddd820c6b244a065c69495473ce5067be1f20ca07b2d6af9f90cffd33e12c18fd719c0d234eb5462a SHA512 06f583efc3855cd8477d8347544f4ae5153a3e50aea74d21968afa7214784ea3ddfc02d0a2b11324120d76a19f2e804d20de11a456b5da929eb6ae469519b174
-DIST m4-1.4.18d.tar.xz 1546856 BLAKE2B fb2deb18237e62d87cc9e4f28d4f95519e90309d515dbfb05b6f042d73f1fa14e02620fdf66febeb22dd7bc4286c0a11085632741b4468a237c273e702f4a4fe SHA512 54205a88b623a605d1905d4959062d622c08d2daf191b862bc857f7cce7b11347e979a3dccbe4ab1c7425202acc144586dfc8f202e298183454b34100d3da51e
+DIST m4-1.4.19.tar.xz 1654908 BLAKE2B 08694485a49c542761fa9a7db4d7609f4dfb08a5c6b785b57f2e14cf1f696c2a1c788bb5eb934e8159a632b63ff071dfe42511d0109d7b1828f46d33c8bf416a SHA512 47f595845c89709727bda0b3fc78e3188ef78ec818965b395532e7041cabe9e49677ee4aca3d042930095a7f8df81de3da1026b23b6897be471f6cf13ddd512b
diff --git a/sys-devel/m4/m4-1.4.19_beta2.ebuild b/sys-devel/m4/m4-1.4.19.ebuild
index 370f1d50f9e3..7e30a110bc38 100644
--- a/sys-devel/m4/m4-1.4.19_beta2.ebuild
+++ b/sys-devel/m4/m4-1.4.19.ebuild
@@ -3,29 +3,43 @@
EAPI=7
-MY_P="${PN}-1.4.18d"
-
DESCRIPTION="GNU macro processor"
HOMEPAGE="https://www.gnu.org/software/m4/m4.html"
if [[ "${PV}" == *_beta* ]] ; then
+ MY_P="${PN}-1.4.18d"
#SRC_URI="mirror://gnu-alpha/${PN}/${MY_P}.tar.xz"
SRC_URI="https://alpha.gnu.org/gnu/${PN}/${MY_P}.tar.xz"
S="${WORKDIR}/${MY_P}"
else
- SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.xz"
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
+
LICENSE="GPL-3"
SLOT="0"
-IUSE="examples"
+IUSE="examples nls"
-# remember: cannot dep on autoconf since it needs us
-BDEPEND="app-arch/xz-utils"
+RDEPEND="
+ virtual/libiconv
+ nls? (
+ sys-devel/gettext
+ virtual/libintl
+ )"
+DEPEND="${RDEPEND}"
+# Remember: cannot dep on autoconf since it needs us
+BDEPEND="app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
src_configure() {
local -a myeconfargs=(
--enable-changeword
+ --with-packager="Gentoo Linux"
+ --with-packager-version="${PVR}"
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+
+ $(usex nls '' '--disable-nls')
+
# Disable automagic dependency over libsigsegv; see bug #278026
ac_cv_libsigsegv=no
)
@@ -42,9 +56,11 @@ src_test() {
src_install() {
default
+
# autoconf-2.60 for instance, first checks gm4, then m4. If we don't have
# gm4, it might find gm4 from outside the prefix on for instance Darwin
use prefix && dosym m4 /usr/bin/gm4
+
if use examples ; then
dodoc -r examples
rm -f "${ED}"/usr/share/doc/${PF}/examples/Makefile*