summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-01-20 09:40:28 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-01-20 09:41:39 +0100
commit0f099b677fd61f5c7ad8f665938718470338caa5 (patch)
tree97b78f1cba40e588de5257484e2cca401ac86693 /sys-devel/make/make-4.3.ebuild
parentapp-vim/gentoo-syntax: Remove old (diff)
downloadgentoo-0f099b677fd61f5c7ad8f665938718470338caa5.tar.gz
gentoo-0f099b677fd61f5c7ad8f665938718470338caa5.tar.bz2
gentoo-0f099b677fd61f5c7ad8f665938718470338caa5.zip
sys-devel/make: Bump to version 4.3. Removed old
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel/make/make-4.3.ebuild')
-rw-r--r--sys-devel/make/make-4.3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-devel/make/make-4.3.ebuild b/sys-devel/make/make-4.3.ebuild
new file mode 100644
index 000000000000..e15a331d2423
--- /dev/null
+++ b/sys-devel/make/make-4.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Standard tool to compile source trees"
+HOMEPAGE="https://www.gnu.org/software/make/make.html"
+if [[ "$(ver_cut 3)" -ge 90 ]] ; then
+ SRC_URI="mirror://gnu-alpha//make/${P}.tar.gz"
+else
+ SRC_URI="mirror://gnu//make/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="guile nls static"
+
+DEPEND="guile? ( >=dev-scheme/guile-1.8:= )"
+BDEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}
+ nls? ( virtual/libintl )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch
+ "${FILESDIR}"/${PN}-4.2-default-cxx.patch
+)
+
+src_prepare() {
+ # sources were moved into src directory
+ cd src || die
+ default
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ local myeconfargs=(
+ --program-prefix=g
+ $(use_with guile)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS NEWS README*
+ if [[ ${USERLAND} == "GNU" ]] ; then
+ # we install everywhere as 'gmake' but on GNU systems,
+ # symlink 'make' to 'gmake'
+ dosym gmake /usr/bin/make
+ dosym gmake.1 /usr/share/man/man1/make.1
+ fi
+}