summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-04 06:45:16 +0100
committerSam James <sam@gentoo.org>2022-05-05 00:28:40 +0100
commit5b06668aa584e919cb9de660da54ee8fa8cac215 (patch)
tree716ee26b7f44d56df7e575e622bb5e96d4616476 /sys-devel/mold
parentnet-irc/irker: drop 2.21 (diff)
downloadgentoo-5b06668aa584e919cb9de660da54ee8fa8cac215.tar.gz
gentoo-5b06668aa584e919cb9de660da54ee8fa8cac215.tar.bz2
gentoo-5b06668aa584e919cb9de660da54ee8fa8cac215.zip
sys-devel/mold: drop 1.1.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/mold')
-rw-r--r--sys-devel/mold/Manifest1
-rw-r--r--sys-devel/mold/mold-1.1.1.ebuild87
2 files changed, 0 insertions, 88 deletions
diff --git a/sys-devel/mold/Manifest b/sys-devel/mold/Manifest
index 0302d4f724fe..268158e76252 100644
--- a/sys-devel/mold/Manifest
+++ b/sys-devel/mold/Manifest
@@ -1,3 +1,2 @@
-DIST mold-1.1.1.tar.gz 4530297 BLAKE2B 78f3beee1b463b3ca028fd72ecf92deb9e8848a4f9cb07c7c549666ef3fef038f395dd30e755be2807dc504b4c3f4893ca359154de9c944c2a03e04f37f5ccea SHA512 981d9737ed7a23134b9bafc04db0cd0233ab4fd588a3b250688dba64936fe84f6736168379fc3e4485273bcef11bca70e5c426b043b5d8b9775ae1cd3aea5b52
DIST mold-1.2.1.tar.gz 4669615 BLAKE2B ba483a479d3eff0ea1dbce0da8c292b6a95c0faee2ac0f52d7be392e41d70e5ff3d7859e43fd721720bfb8331984823f2762acfd9dc51d3f5d8fd0a4865088c9 SHA512 fc39674b00119d09b3275ed7232356f0b25dad1a0f3a498f9db1a4835b6d4f9ea637ca9a643a05591ea895e8751d9bee43cdcb42303beb082462e76ddb42a0f1
DIST mold-1.2.tar.gz 4759743 BLAKE2B 496a4804ac656d52cf54675740091a5e50048a2cc0aae9eab17a08ae88b16e138c364bf76c4d7959cf631d42ed69df3b18207620bf33f6675477ef38bbb0a016 SHA512 1308f5f274867a5d2d2c000a043ce645eff2a0c876fc1bec33c077cd7f5fc0f1f2b983211ca479cebc80f1ed3f3b0ea0d4c8f7e3e7f2124b713354b18ebc8676
diff --git a/sys-devel/mold/mold-1.1.1.ebuild b/sys-devel/mold/mold-1.1.1.ebuild
deleted file mode 100644
index 5ea54e0926db..000000000000
--- a/sys-devel/mold/mold-1.1.1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="A Modern Linker"
-HOMEPAGE="https://github.com/rui314/mold"
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/rui314/mold.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/rui314/mold/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="AGPL-3"
-SLOT="0"
-
-RDEPEND=">=dev-cpp/tbb-2021.4.0:=
- sys-libs/zlib
- !kernel_Darwin? (
- >=dev-libs/mimalloc-2:=
- dev-libs/openssl:=
- )"
-# As of 1.1, xxhash is now a header-only dep, but it's now bundled :(
-# TODO: restore SYSTEM_XXHASH upstream?
-DEPEND="${RDEPEND}"
-
-pkg_pretend() {
- # Requires a c++20 compiler, see #831473
- if [[ ${MERGE_TYPE} != binary ]]; then
- if tc-is-gcc && [[ $(gcc-major-version) -lt 10 ]]; then
- die "${PN} needs at least gcc 10"
- elif tc-is-clang && [[ $(clang-major-version) -lt 12 ]]; then
- die "${PN} needs at least clang 12"
- fi
- fi
-}
-
-src_prepare() {
- default
-
- # Needs unpackaged dwarfdump
- rm test/elf/{compress-debug-sections,compressed-debug-info}.sh || die
-
- # Sandbox sadness
- rm test/elf/run.sh || die
- sed -i 's|$mold-wrapper.so|"& ${LD_PRELOAD}"|' \
- test/elf/mold-wrapper{,2}.sh || die
-
- # static-pie tests require glibc built with static-pie support
- if ! has_version -d 'sys-libs/glibc[static-pie(+)]'; then
- rm test/elf/{hello,ifunc}-static-pie.sh || die
- fi
-}
-
-src_compile() {
- tc-export CC CXX
-
- emake \
- CFLAGS="${CFLAGS}" \
- CXXFLAGS="${CXXFLAGS}" \
- SYSTEM_TBB=1 \
- SYSTEM_MIMALLOC=1 \
- STRIP="true" \
- LIBDIR="${EPREFIX}/usr/$(get_libdir)"
-}
-
-src_test() {
- emake \
- SYSTEM_TBB=1 \
- SYSTEM_MIMALLOC=1 \
- check
-}
-
-src_install() {
- emake \
- SYSTEM_TBB=1 \
- SYSTEM_MIMALLOC=1 \
- DESTDIR="${D}" \
- PREFIX="${EPREFIX}/usr" \
- LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
- STRIP="true" \
- install
-}