summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2020-05-22 03:09:49 -0400
committerMike Frysinger <vapier@gentoo.org>2020-05-22 03:32:49 -0400
commit41189fa2e1db01515ef08662a76c3a58a75bc948 (patch)
tree1f57905a824a115bac76cdfe585d285393d3469e /sys-devel/smatch/smatch-9999.ebuild
parentapp-misc/solaar: Update Manifest (diff)
downloadgentoo-41189fa2e1db01515ef08662a76c3a58a75bc948.tar.gz
gentoo-41189fa2e1db01515ef08662a76c3a58a75bc948.tar.bz2
gentoo-41189fa2e1db01515ef08662a76c3a58a75bc948.zip
sys-devel/smatch: avoid hardcoded pkg-config invocation
It's not a big deal here as we disable most deps, but it avoids "command not found" errors when cross-compiling, and confusing checkers looking for bad pkg-config invocation. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'sys-devel/smatch/smatch-9999.ebuild')
-rw-r--r--sys-devel/smatch/smatch-9999.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/sys-devel/smatch/smatch-9999.ebuild b/sys-devel/smatch/smatch-9999.ebuild
index 4e3cca48e997..8ba49a55ed46 100644
--- a/sys-devel/smatch/smatch-9999.ebuild
+++ b/sys-devel/smatch/smatch-9999.ebuild
@@ -23,12 +23,14 @@ IUSE=""
RDEPEND="dev-db/sqlite"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
sed -i \
-e '/^CFLAGS =/{s:=:+=:;s:-O2 -finline-functions:${CPPFLAGS}:}' \
+ -e 's:pkg-config:$(PKG_CONFIG):' \
Makefile || die
}
@@ -40,6 +42,7 @@ _emake() {
AR="$(tc-getAR)" \
CC="$(tc-getCC)" \
LD='$(CC)' \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
HAVE_GTK2=no \
HAVE_LLVM=no \
HAVE_LIBXML=no \